summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt44
1 files changed, 32 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae089562..609b5eb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,7 +18,7 @@ if(MSVC)
# Turn off some VC++ warnings
SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4668 /wd4311 /wd4800 /wd4820 /wd4503 /wd4244 /wd4345 /wd4996 /wd4396 /wd4018")
else()
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2 -std=c++11 -Wall -Wpedantic -Wsign-compare")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -O2 -std=c++11 -Wall -Wsign-compare")
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -ggdb -O0")
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE}")
endif()
@@ -27,24 +27,36 @@ set(Boost_USE_STATIC_LIBS ON)
set(Boost_USE_MULTITHREADED ON)
set(Boost_USE_STATIC_RUNTIME OFF)
-find_package(GMP)
-if(GMP_FOUND)
- find_package(GMPXX)
-endif()
+#find_package(GMP)
+#if(GMP_FOUND)
+ #find_package(GMPXX)
+#endif()
find_package(CGAL)
# Required programs for unitary tests purpose
-FIND_PROGRAM( GCOVR_PATH gcovr )
-if (GCOVR_PATH)
- message("gcovr found in ${GCOVR_PATH}")
+FIND_PROGRAM( LCOV_PATH lcov )
+if (LCOV_PATH)
+ message("lcov found in ${LCOV_PATH}")
endif()
-# Required programs for unitary tests purpose
-FIND_PROGRAM( GPROF_PATH gprof )
-if (GPROF_PATH)
- message("gprof found in ${GPROF_PATH}")
+
+FIND_PROGRAM( PYTHON_PATH python )
+if (PYTHON_PATH)
+ message("python found in ${PYTHON_PATH}")
endif()
+# Function to add_test cpplint on each header file of the Gudhi module
+function(cpplint_add_tests the_directory)
+ if (PYTHON_PATH)
+ # Cpplint tests on coding style
+ file(GLOB files "${the_directory}/*.h" "${the_directory}/*/*.h")
+ foreach(filename ${files})
+ message(${filename})
+ add_test("${filename}.cpplint" ${CMAKE_SOURCE_DIR}/scripts/check_google_style.sh ${filename} ${CMAKE_SOURCE_DIR}/scripts/cpplint.py)
+ endforeach()
+ endif()
+endfunction(cpplint_add_tests)
+
if(NOT Boost_FOUND)
message(FATAL_ERROR "NOTICE: This demo requires Boost and will not be compiled.")
@@ -67,6 +79,7 @@ else()
include_directories(src/Persistent_cohomology/include/)
include_directories(src/Simplex_tree/include/)
include_directories(src/Skeleton_blocker/include/)
+ include_directories(src/Witness_complex/include/)
add_subdirectory(src/Simplex_tree/test)
add_subdirectory(src/Simplex_tree/example)
@@ -75,6 +88,13 @@ else()
add_subdirectory(src/Skeleton_blocker/test)
add_subdirectory(src/Skeleton_blocker/example)
add_subdirectory(src/Contraction/example)
+ # add_subdirectory(src/Hasse_complex/example)
+ add_subdirectory(src/Witness_complex/test)
+ add_subdirectory(src/Witness_complex/example)
+ # add_subdirectory(src/Alpha_shapes/example)
+ # add_subdirectory(src/Alpha_shapes/test)
+ add_subdirectory(src/Bottleneck/example)
+ add_subdirectory(src/Bottleneck/test)
# data points generator
add_subdirectory(data/points/generator)