summaryrefslogtreecommitdiff
path: root/cython/setup.py.in
diff options
context:
space:
mode:
Diffstat (limited to 'cython/setup.py.in')
-rw-r--r--cython/setup.py.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/cython/setup.py.in b/cython/setup.py.in
index c767e93d..ee381a1b 100644
--- a/cython/setup.py.in
+++ b/cython/setup.py.in
@@ -7,7 +7,7 @@ from Cython.Build import cythonize
Author(s): Vincent Rouvreau
- Copyright (C) 2016 INRIA
+ Copyright (C) 2016 Inria
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -24,7 +24,7 @@ from Cython.Build import cythonize
"""
__author__ = "GUDHI Editorial Board"
-__copyright__ = "Copyright (C) 2016 INRIA"
+__copyright__ = "Copyright (C) 2016 Inria"
__license__ = "GPL v3"
gudhi = Extension(
@@ -46,4 +46,9 @@ setup(
version='@GUDHI_VERSION@',
url='http://gudhi.gforge.inria.fr/',
ext_modules = cythonize(gudhi),
+ install_requires = [
+ "matplotlib",
+ "numpy",
+ "cython",
+ ],
)