summaryrefslogtreecommitdiff
path: root/cython/setup.py.in
diff options
context:
space:
mode:
Diffstat (limited to 'cython/setup.py.in')
-rw-r--r--cython/setup.py.in50
1 files changed, 0 insertions, 50 deletions
diff --git a/cython/setup.py.in b/cython/setup.py.in
deleted file mode 100644
index 4037aab6..00000000
--- a/cython/setup.py.in
+++ /dev/null
@@ -1,50 +0,0 @@
-from distutils.core import setup, Extension
-from Cython.Build import cythonize
-
-"""This file is part of the Gudhi Library. The Gudhi library
- (Geometric Understanding in Higher Dimensions) is a generic C++
- library for computational topology.
-
- Author(s): Vincent Rouvreau
-
- Copyright (C) 2016 Inria
-
- This program is free software: you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation, either version 3 of the License, or
- (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
-"""
-
-__author__ = "GUDHI Editorial Board"
-__copyright__ = "Copyright (C) 2016 Inria"
-__license__ = "GPL v3"
-
-gudhi = Extension(
- "gudhi",
- sources = ['@CMAKE_CURRENT_BINARY_DIR@/gudhi.pyx',],
- language = 'c++',
- extra_compile_args=[@GUDHI_CYTHON_EXTRA_COMPILE_ARGS@],
- extra_link_args=[@GUDHI_CYTHON_EXTRA_LINK_ARGS@],
- libraries=[@GUDHI_CYTHON_LIBRARIES@],
- library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
- include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
- runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
-)
-
-setup(
- name = 'gudhi',
- author='GUDHI Editorial Board',
- author_email='gudhi-contact@lists.gforge.inria.fr',
- version='@GUDHI_VERSION@',
- url='http://gudhi.gforge.inria.fr/',
- ext_modules = cythonize(gudhi),
- install_requires = ["cython",],
-)