summaryrefslogtreecommitdiff
path: root/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch75
1 files changed, 73 insertions, 2 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 973adfc3..82a72911 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -3,9 +3,80 @@ Date: Wed, 25 Sep 2019 15:12:45 +0200
Subject: Disable tests that use DFSG-deleted data files.
---
- src/python/CMakeLists.txt | 31 +------------------------------
- 1 file changed, 1 insertion(+), 30 deletions(-)
+ src/Nerve_GIC/example/CMakeLists.txt | 5 ----
+ src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
+ src/Persistent_cohomology/example/CMakeLists.txt | 4 ---
+ src/Simplex_tree/example/CMakeLists.txt | 2 --
+ src/python/CMakeLists.txt | 31 +-----------------------
+ 5 files changed, 1 insertion(+), 49 deletions(-)
+diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
+index 1667472..37c4759 100644
+--- a/src/Nerve_GIC/example/CMakeLists.txt
++++ b/src/Nerve_GIC/example/CMakeLists.txt
+@@ -12,15 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
+
+ install(TARGETS CoordGIC DESTINATION bin)
+ install(TARGETS FuncGIC DESTINATION bin)
+diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
+index 65a08d9..3f16db9 100644
+--- a/src/Nerve_GIC/utilities/CMakeLists.txt
++++ b/src/Nerve_GIC/utilities/CMakeLists.txt
+@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ endif()
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
+-
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
+diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
+index 94ec13c..4a48d21 100644
+--- a/src/Persistent_cohomology/example/CMakeLists.txt
++++ b/src/Persistent_cohomology/example/CMakeLists.txt
+@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
+ add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+-add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+-add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+
+ install(TARGETS plain_homology DESTINATION bin)
+ install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
+index f99b164..ae302dc 100644
+--- a/src/Simplex_tree/example/CMakeLists.txt
++++ b/src/Simplex_tree/example/CMakeLists.txt
+@@ -25,8 +25,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
+ if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
+ endif()
+- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
+- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
+
+ endif()
+
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
index 5508cbc..1778290 100644
--- a/src/python/CMakeLists.txt