summaryrefslogtreecommitdiff
path: root/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch47
1 files changed, 27 insertions, 20 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index 4b4f24f3..6151ae79 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -5,16 +5,16 @@ Subject: Disable tests that use DFSG-deleted data files.
---
src/Nerve_GIC/example/CMakeLists.txt | 5 ----
src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
- src/Persistent_cohomology/example/CMakeLists.txt | 4 ---
+ src/Persistent_cohomology/example/CMakeLists.txt | 12 ---------
src/Simplex_tree/example/CMakeLists.txt | 2 --
src/python/CMakeLists.txt | 31 +-----------------------
- 5 files changed, 1 insertion(+), 49 deletions(-)
+ 5 files changed, 1 insertion(+), 57 deletions(-)
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
-index 1667472..37c4759 100644
+index 4b0f467..110212d 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
-@@ -12,15 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+@@ -12,14 +12,9 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
# Copy files for not to pollute sources when testing
file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
@@ -28,8 +28,7 @@ index 1667472..37c4759 100644
- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
- install(TARGETS CoordGIC DESTINATION bin)
- install(TARGETS FuncGIC DESTINATION bin)
+ endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
index 65a08d9..3f16db9 100644
--- a/src/Nerve_GIC/utilities/CMakeLists.txt
@@ -50,22 +49,30 @@ index 65a08d9..3f16db9 100644
install(TARGETS Nerve DESTINATION bin)
install(TARGETS VoronoiGIC DESTINATION bin)
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
-index 4c08cd6..a7a7bcd 100644
+index c68c652..9a15a89 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
-@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
- add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
--add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
--add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+@@ -33,18 +33,6 @@ if(TARGET Boost::program_options)
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+ endif()
- install(TARGETS plain_homology DESTINATION bin)
- install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+-if(TARGET Boost::program_options)
+- add_executable(persistence_from_file persistence_from_file.cpp)
+- target_link_libraries(persistence_from_file Boost::program_options)
+- if (TBB_FOUND)
+- target_link_libraries(persistence_from_file ${TBB_LIBRARIES})
+- endif()
+- add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+- add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+-endif()
+-
+ if(GMP_FOUND)
+ if(GMPXX_FOUND)
+ if(TARGET Boost::program_options)
diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
-index a0aabee..5c572f8 100644
+index 73b2c6f..a6dd0b1 100644
--- a/src/Simplex_tree/example/CMakeLists.txt
+++ b/src/Simplex_tree/example/CMakeLists.txt
@@ -28,8 +28,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
@@ -78,10 +85,10 @@ index a0aabee..5c572f8 100644
endif()
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 4f26481..99b648b 100644
+index 5c1402a..a45e13a 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -381,36 +381,7 @@ if(PYTHONINTERP_FOUND)
+@@ -386,36 +386,7 @@ if(PYTHONINTERP_FOUND)
add_gudhi_py_test(test_bottleneck_distance)
endif()