summaryrefslogtreecommitdiff
path: root/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch')
-rw-r--r--debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch b/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch
new file mode 100644
index 00000000..abf2a450
--- /dev/null
+++ b/debian/patches/0002-Disable-Sphinx-test-since-we-re-not-currently-using.patch
@@ -0,0 +1,23 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:18:26 +0200
+Subject: Disable Sphinx test since we're not currently using.
+
+---
+ cython/CMakeLists.txt | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index 17d440e..9194e45 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -280,10 +280,5 @@ if(CYTHON_FOUND)
+ DEPENDS "${CMAKE_CURRENT_BINARY_DIR}/gudhi.so"
+ COMMENT "${GUDHI_SPHINX_MESSAGE}" VERBATIM)
+
+- add_test(NAME sphinx_py_test
+- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
+- ${SPHINX_PATH} -b doctest ${CMAKE_CURRENT_SOURCE_DIR}/doc ${CMAKE_CURRENT_BINARY_DIR}/doctest)
+-
+ endif(SPHINX_PATH AND NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ endif(CYTHON_FOUND)