summaryrefslogtreecommitdiff
path: root/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch121
1 files changed, 0 insertions, 121 deletions
diff --git a/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch
deleted file mode 100644
index e59a4f8b..00000000
--- a/debian/patches/0002-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 10 Sep 2018 05:17:29 +0200
-Subject: Disable tests that use DFSG-deleted data files.
-
----
- cython/CMakeLists.txt | 30 ----------------------------
- example/Nerve_GIC/CMakeLists.txt | 6 ------
- example/Persistent_cohomology/CMakeLists.txt | 4 ----
- example/Simplex_tree/CMakeLists.txt | 2 --
- utilities/Nerve_GIC/CMakeLists.txt | 8 --------
- 5 files changed, 50 deletions(-)
-
-diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
-index 829d53b..219b99e 100644
---- a/cython/CMakeLists.txt
-+++ b/cython/CMakeLists.txt
-@@ -265,36 +265,6 @@ if(CYTHON_FOUND)
-
- add_gudhi_py_test(test_bottleneck_distance)
-
-- # Cover complex
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- add_test(NAME cover_complex_nerve_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
-- -f human.off -c 2 -r 10 -g 0.3)
--
-- add_test(NAME cover_complex_coordinate_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
-- -f human.off -c 0 -v)
--
-- add_test(NAME cover_complex_functional_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
-- -o lucky_cat.off
-- -f lucky_cat_PCA1 -v)
--
-- add_test(NAME cover_complex_voronoi_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
-- -f human.off -n 700 -v)
--
-- add_gudhi_py_test(test_cover_complex)
- endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-
- if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.7.0)
-diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
-index fdecf86..f63e08e 100644
---- a/example/Nerve_GIC/CMakeLists.txt
-+++ b/example/Nerve_GIC/CMakeLists.txt
-@@ -12,16 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-
- # Copy files for not to pollute sources when testing
- file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
- add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
- "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
-
-- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
--
- install(TARGETS CoordGIC DESTINATION bin)
- install(TARGETS FuncGIC DESTINATION bin)
-
-diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
-index 0f73151..4cac586 100644
---- a/example/Persistent_cohomology/CMakeLists.txt
-+++ b/example/Persistent_cohomology/CMakeLists.txt
-@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
- add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
--add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
--add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
-
- install(TARGETS plain_homology DESTINATION bin)
- install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
-diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
-index 857e851..48bb069 100644
---- a/example/Simplex_tree/CMakeLists.txt
-+++ b/example/Simplex_tree/CMakeLists.txt
-@@ -29,8 +29,6 @@ if(GMP_FOUND AND CGAL_FOUND)
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
-- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
-
-diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
-index 215f9df..20aeb8e 100644
---- a/utilities/Nerve_GIC/CMakeLists.txt
-+++ b/utilities/Nerve_GIC/CMakeLists.txt
-@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
- endif()
-
- file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- # Copy files for not to pollute sources when testing
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
--
-- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
-- "human.off" "2" "10" "0.3")
--
-- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
-- "human.off" "100")
-
- install(TARGETS Nerve DESTINATION bin)
- install(TARGETS VoronoiGIC DESTINATION bin)