summaryrefslogtreecommitdiff
path: root/debian/patches/0002-Don-t-use-static-boost.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-Don-t-use-static-boost.patch')
-rw-r--r--debian/patches/0002-Don-t-use-static-boost.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0002-Don-t-use-static-boost.patch b/debian/patches/0002-Don-t-use-static-boost.patch
new file mode 100644
index 00000000..44ca1ac3
--- /dev/null
+++ b/debian/patches/0002-Don-t-use-static-boost.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 14 Oct 2016 10:31:08 +0200
+Subject: Don't use static boost.
+
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a1b39c3..0f349f8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -65,7 +65,7 @@ else()
+ message("++ Release compilation flags are: ${CMAKE_CXX_FLAGS} ${CMAKE_CXX_FLAGS_RELEASE}")
+ endif()
+
+- set(Boost_USE_STATIC_LIBS ON)
++ set(Boost_USE_STATIC_LIBS OFF)
+ set(Boost_USE_MULTITHREADED ON)
+ set(Boost_USE_STATIC_RUNTIME OFF)
+