summaryrefslogtreecommitdiff
path: root/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch')
-rw-r--r--debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch b/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch
new file mode 100644
index 00000000..75a4420c
--- /dev/null
+++ b/debian/patches/0003-Disable-some-tests-that-uncleanly-write-outside-the-.patch
@@ -0,0 +1,32 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 14 Oct 2016 11:04:19 +0200
+Subject: Disable some tests that uncleanly write outside the build directory.
+
+---
+ example/Bitmap_cubical_complex/CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/example/Bitmap_cubical_complex/CMakeLists.txt b/example/Bitmap_cubical_complex/CMakeLists.txt
+index 2fddc51..eb9990b 100644
+--- a/example/Bitmap_cubical_complex/CMakeLists.txt
++++ b/example/Bitmap_cubical_complex/CMakeLists.txt
+@@ -6,8 +6,8 @@ target_link_libraries(Bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
+ endif()
+-add_test(Bitmap_cubical_complex_one_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt)
+-add_test(Bitmap_cubical_complex_two_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt)
++#add_test(Bitmap_cubical_complex_one_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt)
++#add_test(Bitmap_cubical_complex_two_sphere ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex ${CMAKE_SOURCE_DIR}/data/bitmap/CubicalTwoSphere.txt)
+
+ add_executable ( Random_bitmap_cubical_complex Random_bitmap_cubical_complex.cpp )
+ target_link_libraries(Random_bitmap_cubical_complex ${Boost_SYSTEM_LIBRARY})
+@@ -21,6 +21,6 @@ target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${Boos
+ if (TBB_FOUND)
+ target_link_libraries(Bitmap_cubical_complex_periodic_boundary_conditions ${TBB_LIBRARIES})
+ endif()
+-add_test(Bitmap_cubical_complex_periodic_2d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt)
+-add_test(Bitmap_cubical_complex_periodic_3d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt)
++#add_test(Bitmap_cubical_complex_periodic_2d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/2d_torus.txt)
++#add_test(Bitmap_cubical_complex_periodic_3d_torus ${CMAKE_CURRENT_BINARY_DIR}/Bitmap_cubical_complex_periodic_boundary_conditions ${CMAKE_SOURCE_DIR}/data/bitmap/3d_torus.txt)
+