summaryrefslogtreecommitdiff
path: root/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch68
1 files changed, 58 insertions, 10 deletions
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
index eade3da7..54c13639 100644
--- a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -1,19 +1,45 @@
-From f31347031ea99c60d11064ec28bc27805b5c28b9 Mon Sep 17 00:00:00 2001
+From 9218bee33900e1e203991607e038f029a2216c3c Mon Sep 17 00:00:00 2001
From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 9 Oct 2017 14:15:02 +0200
-Subject: [PATCH 3/4] Disable tests that use DFSG-deleted data files.
+Date: Mon, 5 Feb 2018 10:15:40 +0100
+Subject: [PATCH 3/5] Disable tests that use DFSG-deleted data files.
---
- example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
- example/Simplex_tree/CMakeLists.txt | 4 ++--
- example/common/CMakeLists.txt | 4 ++--
- 3 files changed, 8 insertions(+), 8 deletions(-)
+ example/Nerve_GIC/CMakeLists.txt | 10 +++++-----
+ example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
+ example/Simplex_tree/CMakeLists.txt | 4 ++--
+ example/common/CMakeLists.txt | 4 ++--
+ utilities/Nerve_GIC/CMakeLists.txt | 10 +++++-----
+ 5 files changed, 18 insertions(+), 18 deletions(-)
+diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
+index f262692..825974c 100644
+--- a/example/Nerve_GIC/CMakeLists.txt
++++ b/example/Nerve_GIC/CMakeLists.txt
+@@ -13,14 +13,14 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
++ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
++ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "tore3D_1307.off" "0")
+
+- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "lucky_cat.off"
+- "lucky_cat_PCA1")
++ #add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
++ # "lucky_cat.off"
++ # "lucky_cat_PCA1")
+
+ endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
-index f47de4c..8f11ea0 100644
+index 18e2913..e2dca6d 100644
--- a/example/Persistent_cohomology/CMakeLists.txt
+++ b/example/Persistent_cohomology/CMakeLists.txt
-@@ -41,10 +41,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+@@ -29,10 +29,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
"${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
@@ -29,7 +55,7 @@ index f47de4c..8f11ea0 100644
install(TARGETS plain_homology DESTINATION bin)
install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
-index e22cc92..99da80f 100644
+index b33b2d0..1cba524 100644
--- a/example/Simplex_tree/CMakeLists.txt
+++ b/example/Simplex_tree/CMakeLists.txt
@@ -30,8 +30,8 @@ if(GMP_FOUND AND CGAL_FOUND)
@@ -58,6 +84,28 @@ index afe865d..2ad4a64 100644
install(TARGETS vector_double_off_reader DESTINATION bin)
+diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
+index 7762c8a..c41898b 100644
+--- a/utilities/Nerve_GIC/CMakeLists.txt
++++ b/utilities/Nerve_GIC/CMakeLists.txt
+@@ -13,12 +13,12 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
+
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
++ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+
+- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
++ #add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
++ # "human.off" "2" "10" "0.3")
+
+- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
++ #add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
++ # "human.off" "100")
+
+ endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
--
2.11.0