summaryrefslogtreecommitdiff
path: root/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
new file mode 100644
index 00000000..279c6091
--- /dev/null
+++ b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -0,0 +1,63 @@
+From c80f7efa2fbdc3152fde015505be0e6b64074c49 Mon Sep 17 00:00:00 2001
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 9 Oct 2017 14:15:02 +0200
+Subject: [PATCH 3/3] Disable tests that use DFSG-deleted data files.
+
+---
+ example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
+ example/Simplex_tree/CMakeLists.txt | 4 ++--
+ example/common/CMakeLists.txt | 4 ++--
+ 3 files changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
+index f47de4c..8f11ea0 100644
+--- a/example/Persistent_cohomology/CMakeLists.txt
++++ b/example/Persistent_cohomology/CMakeLists.txt
+@@ -41,10 +41,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
+ "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
+ add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
+ "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
+-add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
+-add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
+- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
++#add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
++# "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
++#add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
++# "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
+
+ install(TARGETS plain_homology DESTINATION bin)
+ install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
+diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
+index e22cc92..99da80f 100644
+--- a/example/Simplex_tree/CMakeLists.txt
++++ b/example/Simplex_tree/CMakeLists.txt
+@@ -30,8 +30,8 @@ if(GMP_FOUND AND CGAL_FOUND)
+ if (TBB_FOUND)
+ target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
+ endif()
+- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
+- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
++# add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
++# "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
+
+ install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
+
+diff --git a/example/common/CMakeLists.txt b/example/common/CMakeLists.txt
+index afe865d..2ad4a64 100644
+--- a/example/common/CMakeLists.txt
++++ b/example/common/CMakeLists.txt
+@@ -3,8 +3,8 @@ project(Common_examples)
+
+ add_executable ( vector_double_off_reader example_vector_double_points_off_reader.cpp )
+ target_link_libraries(vector_double_off_reader ${CGAL_LIBRARY})
+-add_test(NAME Common_example_vector_double_off_reader COMMAND $<TARGET_FILE:vector_double_off_reader>
+- "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off")
++#add_test(NAME Common_example_vector_double_off_reader COMMAND $<TARGET_FILE:vector_double_off_reader>
++# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off")
+
+ install(TARGETS vector_double_off_reader DESTINATION bin)
+
+--
+2.11.0
+