summaryrefslogtreecommitdiff
path: root/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch')
-rw-r--r--debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch107
1 files changed, 0 insertions, 107 deletions
diff --git a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
deleted file mode 100644
index 4edf1caa..00000000
--- a/debian/patches/0003-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ /dev/null
@@ -1,107 +0,0 @@
-From: Gard Spreemann <gspreemann@gmail.com>
-Date: Mon, 5 Feb 2018 10:15:40 +0100
-Subject: [PATCH 3/5] Disable tests that use DFSG-deleted data files.
-
----
- example/Nerve_GIC/CMakeLists.txt | 10 +++++-----
- example/Persistent_cohomology/CMakeLists.txt | 8 ++++----
- example/Simplex_tree/CMakeLists.txt | 4 ++--
- example/common/CMakeLists.txt | 4 ++--
- utilities/Nerve_GIC/CMakeLists.txt | 10 +++++-----
- 5 files changed, 18 insertions(+), 18 deletions(-)
-
-diff --git a/example/Nerve_GIC/CMakeLists.txt b/example/Nerve_GIC/CMakeLists.txt
-index f262692..825974c 100644
---- a/example/Nerve_GIC/CMakeLists.txt
-+++ b/example/Nerve_GIC/CMakeLists.txt
-@@ -13,14 +13,14 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-
- # Copy files for not to pollute sources when testing
- file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-+ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-+ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
- add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
- "tore3D_1307.off" "0")
-
-- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
-- "lucky_cat.off"
-- "lucky_cat_PCA1")
-+ #add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
-+ # "lucky_cat.off"
-+ # "lucky_cat_PCA1")
-
- endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-diff --git a/example/Persistent_cohomology/CMakeLists.txt b/example/Persistent_cohomology/CMakeLists.txt
-index 18e2913..e2dca6d 100644
---- a/example/Persistent_cohomology/CMakeLists.txt
-+++ b/example/Persistent_cohomology/CMakeLists.txt
-@@ -29,10 +29,10 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
- add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
--add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
--add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
-+#add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-+# "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
-+#add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-+# "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
-
- install(TARGETS plain_homology DESTINATION bin)
- install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
-diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
-index b33b2d0..1cba524 100644
---- a/example/Simplex_tree/CMakeLists.txt
-+++ b/example/Simplex_tree/CMakeLists.txt
-@@ -30,8 +30,8 @@ if(GMP_FOUND AND CGAL_FOUND)
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
-- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-+# add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-+# "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
-
-diff --git a/example/common/CMakeLists.txt b/example/common/CMakeLists.txt
-index afe865d..2ad4a64 100644
---- a/example/common/CMakeLists.txt
-+++ b/example/common/CMakeLists.txt
-@@ -3,8 +3,8 @@ project(Common_examples)
-
- add_executable ( vector_double_off_reader example_vector_double_points_off_reader.cpp )
- target_link_libraries(vector_double_off_reader ${CGAL_LIBRARY})
--add_test(NAME Common_example_vector_double_off_reader COMMAND $<TARGET_FILE:vector_double_off_reader>
-- "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off")
-+#add_test(NAME Common_example_vector_double_off_reader COMMAND $<TARGET_FILE:vector_double_off_reader>
-+# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off")
-
- install(TARGETS vector_double_off_reader DESTINATION bin)
-
-diff --git a/utilities/Nerve_GIC/CMakeLists.txt b/utilities/Nerve_GIC/CMakeLists.txt
-index 7762c8a..c41898b 100644
---- a/utilities/Nerve_GIC/CMakeLists.txt
-+++ b/utilities/Nerve_GIC/CMakeLists.txt
-@@ -13,12 +13,12 @@ if (NOT CGAL_VERSION VERSION_LESS 4.8.1)
-
- file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- # Copy files for not to pollute sources when testing
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-+ #file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
-- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
-- "human.off" "2" "10" "0.3")
-+ #add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
-+ # "human.off" "2" "10" "0.3")
-
-- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
-- "human.off" "100")
-+ #add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
-+ # "human.off" "100")
-
- endif (NOT CGAL_VERSION VERSION_LESS 4.8.1)