summaryrefslogtreecommitdiff
path: root/debian/patches/0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch')
-rw-r--r--debian/patches/0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch b/debian/patches/0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
new file mode 100644
index 00000000..f5c6e30d
--- /dev/null
+++ b/debian/patches/0003-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:14:52 +0200
+Subject: Don't set runtime library dirs for Python extensions.
+
+---
+ src/python/setup.py.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/setup.py.in b/src/python/setup.py.in
+index 3f1d442..1011f38 100644
+--- a/src/python/setup.py.in
++++ b/src/python/setup.py.in
+@@ -24,7 +24,7 @@ extra_link_args=[@GUDHI_PYTHON_EXTRA_LINK_ARGS@]
+ libraries=[@GUDHI_PYTHON_LIBRARIES@]
+ library_dirs=[@GUDHI_PYTHON_LIBRARY_DIRS@]
+ include_dirs = [numpy_get_include(), '@CMAKE_CURRENT_SOURCE_DIR@/gudhi/', @GUDHI_PYTHON_INCLUDE_DIRS@]
+-runtime_library_dirs=[@GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS@]
++runtime_library_dirs=[]
+
+ # Create ext_modules list from module list
+ ext_modules = []