summaryrefslogtreecommitdiff
path: root/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch')
-rw-r--r--debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch b/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
new file mode 100644
index 00000000..b2b8c39c
--- /dev/null
+++ b/debian/patches/0004-Don-t-set-runtime-library-dirs-for-Python-extensions.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Mon, 10 Sep 2018 05:19:07 +0200
+Subject: Don't set runtime library dirs for Python extensions.
+
+---
+ cython/setup.py.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/setup.py.in b/cython/setup.py.in
+index 4037aab..b0141aa 100644
+--- a/cython/setup.py.in
++++ b/cython/setup.py.in
+@@ -36,7 +36,7 @@ gudhi = Extension(
+ libraries=[@GUDHI_CYTHON_LIBRARIES@],
+ library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
+ include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
+- runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
++ runtime_library_dirs=[],
+ )
+
+ setup(