summaryrefslogtreecommitdiff
path: root/debian/patches/0004-Force-linking-of-Python-module-with-CGAL.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0004-Force-linking-of-Python-module-with-CGAL.patch')
-rw-r--r--debian/patches/0004-Force-linking-of-Python-module-with-CGAL.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0004-Force-linking-of-Python-module-with-CGAL.patch b/debian/patches/0004-Force-linking-of-Python-module-with-CGAL.patch
new file mode 100644
index 00000000..75c516cb
--- /dev/null
+++ b/debian/patches/0004-Force-linking-of-Python-module-with-CGAL.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Wed, 25 Sep 2019 15:16:27 +0200
+Subject: Force linking of Python module with CGAL.
+
+---
+ src/python/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 1778290..4c6840f 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -129,7 +129,7 @@ if(PYTHONINTERP_FOUND)
+ set(GUDHI_PYTHON_EXTRA_COMPILE_ARGS "${GUDHI_PYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_HEADER_ONLY', ")
+ else(CGAL_HEADER_ONLY)
+ add_gudhi_debug_info("CGAL version ${CGAL_VERSION}")
+- add_GUDHI_PYTHON_lib("${CGAL_LIBRARY}")
++ add_GUDHI_PYTHON_lib("${CGAL_LIBRARIES_DIR}/libCGAL.so")
+ set(GUDHI_PYTHON_LIBRARY_DIRS "${GUDHI_PYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
+ message("** Add CGAL ${CGAL_LIBRARIES_DIR}")
+ # If CGAL is not header only, CGAL library may link with boost system,