summaryrefslogtreecommitdiff
path: root/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch')
-rw-r--r--debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch b/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch
new file mode 100644
index 00000000..cea5de9d
--- /dev/null
+++ b/debian/patches/0006-Force-linking-of-Python-module-with-CGAL.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Fri, 15 Jun 2018 13:23:55 +0200
+Subject: Force linking of Python module with CGAL.
+
+---
+ cython/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cython/CMakeLists.txt b/cython/CMakeLists.txt
+index 9194e45..90ca2b7 100644
+--- a/cython/CMakeLists.txt
++++ b/cython/CMakeLists.txt
+@@ -78,7 +78,7 @@ if(CYTHON_FOUND)
+ if(CGAL_HEADER_ONLY)
+ set(GUDHI_CYTHON_EXTRA_COMPILE_ARGS "${GUDHI_CYTHON_EXTRA_COMPILE_ARGS}'-DCGAL_HEADER_ONLY', ")
+ else(CGAL_HEADER_ONLY)
+- add_gudhi_cython_lib(${CGAL_LIBRARY})
++ add_gudhi_cython_lib("${CGAL_LIBRARIES_DIR}/libCGAL.so")
+ set(GUDHI_CYTHON_LIBRARY_DIRS "${GUDHI_CYTHON_LIBRARY_DIRS}'${CGAL_LIBRARIES_DIR}', ")
+ # If CGAL is not header only, CGAL library may link with boost system,
+ add_gudhi_cython_lib(${Boost_SYSTEM_LIBRARY})