summaryrefslogtreecommitdiff
path: root/debian/patches/0006-Install-Python-module-in-correct-location.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0006-Install-Python-module-in-correct-location.patch')
-rw-r--r--debian/patches/0006-Install-Python-module-in-correct-location.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0006-Install-Python-module-in-correct-location.patch b/debian/patches/0006-Install-Python-module-in-correct-location.patch
new file mode 100644
index 00000000..0b4a8f64
--- /dev/null
+++ b/debian/patches/0006-Install-Python-module-in-correct-location.patch
@@ -0,0 +1,21 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Thu, 26 Sep 2019 13:26:22 +0200
+Subject: Install Python module in correct location.
+
+---
+ src/python/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
+index 99b648b..162bd27 100644
+--- a/src/python/CMakeLists.txt
++++ b/src/python/CMakeLists.txt
+@@ -267,7 +267,7 @@ if(PYTHONINTERP_FOUND)
+ add_custom_target(python ALL DEPENDS gudhi.so
+ COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
+
+- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
++ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} setup.py install --root=${CMAKE_SOURCE_DIR}/debian/tmp --single-version-externally-managed --install-layout=deb WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})")
+
+ # Documentation generation is available through sphinx - requires all modules
+ # Make it first as sphinx test is by far the longest test which is nice when testing in parallel