summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch134
-rw-r--r--debian/patches/0002-Use-system-MathJax.patch6
-rw-r--r--debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch21
-rw-r--r--debian/patches/0003-Offline-header-for-docs.patch (renamed from debian/patches/0004-Offline-header-for-docs.patch)8
-rw-r--r--debian/patches/0004-Disable-Sphinx.patch37
-rw-r--r--debian/patches/0005-Disable-Sphinx.patch20
-rw-r--r--debian/patches/0005-Support-Hera-1.0.patch66
-rw-r--r--debian/patches/0006-Install-Python-module-in-correct-location.patch21
-rw-r--r--debian/patches/0007-Move-towards-reproducible-builds.patch23
-rw-r--r--debian/patches/0008-Don-t-try-to-install-Hera.patch22
-rw-r--r--debian/patches/0009-Keep-POT-optional.patch24
-rw-r--r--debian/patches/0010-Work-around-963955.patch120
-rw-r--r--debian/patches/series11
13 files changed, 149 insertions, 364 deletions
diff --git a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
index f574ed63..af6b0afb 100644
--- a/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
+++ b/debian/patches/0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
@@ -3,119 +3,57 @@ Date: Wed, 25 Sep 2019 15:12:45 +0200
Subject: Disable tests that use DFSG-deleted data files.
---
- src/Nerve_GIC/example/CMakeLists.txt | 5 ----
- src/Nerve_GIC/utilities/CMakeLists.txt | 8 ------
- src/Persistent_cohomology/example/CMakeLists.txt | 4 ---
- src/Simplex_tree/example/CMakeLists.txt | 2 --
- src/python/CMakeLists.txt | 31 +-----------------------
- 5 files changed, 1 insertion(+), 49 deletions(-)
+ src/Nerve_GIC/example/CMakeLists.txt | 6 ------
+ src/Nerve_GIC/utilities/CMakeLists.txt | 7 -------
+ src/python/CMakeLists.txt | 3 ---
+ 3 files changed, 16 deletions(-)
diff --git a/src/Nerve_GIC/example/CMakeLists.txt b/src/Nerve_GIC/example/CMakeLists.txt
-index 1667472..37c4759 100644
+index 9faf1f3..bbfa592 100644
--- a/src/Nerve_GIC/example/CMakeLists.txt
+++ b/src/Nerve_GIC/example/CMakeLists.txt
-@@ -12,15 +12,10 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
+@@ -10,12 +10,6 @@ endif()
- # Copy files for not to pollute sources when testing
- file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+ file(COPY "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+-file(COPY "${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
- add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
- "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
-
-- add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
-- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
-
- install(TARGETS CoordGIC DESTINATION bin)
- install(TARGETS FuncGIC DESTINATION bin)
+ add_test(NAME Nerve_GIC_example_CoordGIC COMMAND $<TARGET_FILE:CoordGIC>
+ "${CMAKE_CURRENT_BINARY_DIR}/tore3D_1307.off" "0")
+-
+-add_test(NAME Nerve_GIC_example_FuncGIC COMMAND $<TARGET_FILE:FuncGIC>
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat.off"
+- "${CMAKE_CURRENT_BINARY_DIR}/lucky_cat_PCA1")
diff --git a/src/Nerve_GIC/utilities/CMakeLists.txt b/src/Nerve_GIC/utilities/CMakeLists.txt
-index 65a08d9..3f16db9 100644
+index 4521a99..e28973f 100644
--- a/src/Nerve_GIC/utilities/CMakeLists.txt
+++ b/src/Nerve_GIC/utilities/CMakeLists.txt
-@@ -11,14 +11,6 @@ if (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- endif()
+@@ -10,13 +10,6 @@ endif()
- file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- # Copy files for not to pollute sources when testing
-- file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ file(COPY KeplerMapperVisuFromTxtFile.py km.py DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ # Copy files for not to pollute sources when testing
+-file(COPY "${CMAKE_SOURCE_DIR}/data/points/human.off" DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-
-- add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
-- "human.off" "2" "10" "0.3")
+-add_test(NAME Nerve_GIC_utilities_nerve COMMAND $<TARGET_FILE:Nerve>
+- "human.off" "2" "10" "0.3")
-
-- add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
-- "human.off" "100")
-
- install(TARGETS Nerve DESTINATION bin)
- install(TARGETS VoronoiGIC DESTINATION bin)
-diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
-index 4c08cd6..a7a7bcd 100644
---- a/src/Persistent_cohomology/example/CMakeLists.txt
-+++ b/src/Persistent_cohomology/example/CMakeLists.txt
-@@ -28,10 +28,6 @@ add_test(NAME Persistent_cohomology_example_from_rips_step_by_step_on_tore_3D CO
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "-r" "0.25" "-m" "0.5" "-d" "3" "-p" "3")
- add_test(NAME Persistent_cohomology_example_via_boundary_matrix COMMAND $<TARGET_FILE:rips_persistence_via_boundary_matrix>
- "${CMAKE_SOURCE_DIR}/data/points/Kl.off" "-r" "0.16" "-d" "3" "-p" "3" "-m" "100")
--add_test(NAME Persistent_cohomology_example_from_file_3_2_0 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "2" "-m" "0")
--add_test(NAME Persistent_cohomology_example_from_file_3_3_100 COMMAND $<TARGET_FILE:persistence_from_file>
-- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/bunny_5000_complex.fsc" "-p" "3" "-m" "100")
-
- install(TARGETS plain_homology DESTINATION bin)
- install(TARGETS persistence_from_simple_simplex_tree DESTINATION bin)
-diff --git a/src/Simplex_tree/example/CMakeLists.txt b/src/Simplex_tree/example/CMakeLists.txt
-index a0aabee..5c572f8 100644
---- a/src/Simplex_tree/example/CMakeLists.txt
-+++ b/src/Simplex_tree/example/CMakeLists.txt
-@@ -28,8 +28,6 @@ if(GMP_FOUND AND NOT CGAL_VERSION VERSION_LESS 4.11.0)
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
-- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
-- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- endif()
+-add_test(NAME Nerve_GIC_utilities_VoronoiGIC COMMAND $<TARGET_FILE:VoronoiGIC>
+- "human.off" "100")
+ install(TARGETS Nerve DESTINATION bin)
+ install(TARGETS VoronoiGIC DESTINATION bin)
diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index ab08cd6..1a2f18b 100644
+index 39e2acd..b3f2268 100644
--- a/src/python/CMakeLists.txt
+++ b/src/python/CMakeLists.txt
-@@ -355,36 +355,7 @@ if(PYTHONINTERP_FOUND)
-
- add_gudhi_py_test(test_bottleneck_distance)
-
-- # Cover complex
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
-- add_test(NAME cover_complex_nerve_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/nerve_of_a_covering.py"
-- -f human.off -c 2 -r 10 -g 0.3)
--
-- add_test(NAME cover_complex_coordinate_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/coordinate_graph_induced_complex.py"
-- -f human.off -c 0 -v)
--
-- add_test(NAME cover_complex_functional_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/functional_graph_induced_complex.py"
-- -o lucky_cat.off
-- -f lucky_cat_PCA1 -v)
--
-- add_test(NAME cover_complex_voronoi_gic_example_py_test
-- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-- COMMAND ${CMAKE_COMMAND} -E env "PYTHONPATH=${CMAKE_CURRENT_BINARY_DIR}"
-- ${PYTHON_EXECUTABLE} "${CMAKE_CURRENT_SOURCE_DIR}/example/voronoi_graph_induced_complex.py"
-- -f human.off -n 700 -v)
--
-- add_gudhi_py_test(test_cover_complex)
-+
+@@ -435,9 +435,6 @@ if(PYTHONINTERP_FOUND)
endif (NOT CGAL_VERSION VERSION_LESS 4.11.0)
- if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ # Cover complex
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/human.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat.off DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+- file(COPY ${CMAKE_SOURCE_DIR}/data/points/COIL_database/lucky_cat_PCA1 DESTINATION ${CMAKE_CURRENT_BINARY_DIR}/)
+ add_test(NAME cover_complex_nerve_example_py_test
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMAND ${CMAKE_COMMAND} -E env "${GUDHI_PYTHON_PATH_ENV}"
diff --git a/debian/patches/0002-Use-system-MathJax.patch b/debian/patches/0002-Use-system-MathJax.patch
index 2985548e..e5c328ee 100644
--- a/debian/patches/0002-Use-system-MathJax.patch
+++ b/debian/patches/0002-Use-system-MathJax.patch
@@ -7,14 +7,14 @@ Subject: Use system MathJax.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
-index 49e781b..52b8cbe 100644
+index d5664a4..093aaa5 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
-@@ -1441,7 +1441,7 @@ MATHJAX_FORMAT = HTML-CSS
+@@ -1499,7 +1499,7 @@ MATHJAX_FORMAT = HTML-CSS
# The default value is: http://cdn.mathjax.org/mathjax/latest.
# This tag requires that the tag USE_MATHJAX is set to YES.
--MATHJAX_RELPATH = https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.2
+-MATHJAX_RELPATH =
+MATHJAX_RELPATH = /usr/share/javascript/mathjax
# The MATHJAX_EXTENSIONS tag can be used to specify one or more MathJax
diff --git a/debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch b/debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch
deleted file mode 100644
index 0a20ce1e..00000000
--- a/debian/patches/0003-Force-linking-against-libatomic-for-parts-that-use-T.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Wed, 25 Sep 2019 15:18:08 +0200
-Subject: Force linking against libatomic for parts that use TBB.
-
----
- src/cmake/modules/FindTBB.cmake | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/cmake/modules/FindTBB.cmake b/src/cmake/modules/FindTBB.cmake
-index 13f4d92..6baa8d7 100644
---- a/src/cmake/modules/FindTBB.cmake
-+++ b/src/cmake/modules/FindTBB.cmake
-@@ -375,6 +375,8 @@ if (TBB_INCLUDE_DIR)
- endif(NOT TBB_without_pthread)
- endif(UNIX AND NOT APPLE)
-
-+ list(APPEND ALL_TBB_LIBRARIES atomic)
-+
- set (TBB_LIBRARIES ${ALL_TBB_LIBRARIES}
- CACHE PATH "TBB libraries" FORCE)
-
diff --git a/debian/patches/0004-Offline-header-for-docs.patch b/debian/patches/0003-Offline-header-for-docs.patch
index b6dba1ab..91cad23d 100644
--- a/debian/patches/0004-Offline-header-for-docs.patch
+++ b/debian/patches/0003-Offline-header-for-docs.patch
@@ -7,15 +7,15 @@ Subject: Offline header for docs.
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Doxyfile.in b/src/Doxyfile.in
-index 52b8cbe..f516ef7 100644
+index 093aaa5..152041e 100644
--- a/src/Doxyfile.in
+++ b/src/Doxyfile.in
-@@ -1046,7 +1046,7 @@ HTML_FILE_EXTENSION = .html
+@@ -1095,7 +1095,7 @@ HTML_FILE_EXTENSION = .html
# of the possible markers and block names see the documentation.
# This tag requires that the tag GENERATE_HTML is set to YES.
--HTML_HEADER = doc/common/header.html
-+HTML_HEADER = doc/common/offline_header.html
+-HTML_HEADER = @GUDHI_DOXYGEN_COMMON_DOC_PATH@/header.html
++HTML_HEADER = @GUDHI_DOXYGEN_COMMON_DOC_PATH@/offline_header.html
# The HTML_FOOTER tag can be used to specify a user-defined HTML footer for each
# generated HTML page. If the tag is left blank doxygen will generate a standard
diff --git a/debian/patches/0004-Disable-Sphinx.patch b/debian/patches/0004-Disable-Sphinx.patch
new file mode 100644
index 00000000..9d22ec9d
--- /dev/null
+++ b/debian/patches/0004-Disable-Sphinx.patch
@@ -0,0 +1,37 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Tue, 21 Jan 2020 10:36:48 +0100
+Subject: Disable Sphinx.
+
+---
+ src/cmake/modules/GUDHI_third_party_libraries.cmake | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
+index 2cf6787..e36e22b 100644
+--- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
++++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
+@@ -151,7 +151,6 @@ if (WITH_GUDHI_PYTHON)
+ find_python_module("matplotlib")
+ find_python_module("numpy")
+ find_python_module("scipy")
+- find_python_module("sphinx")
+ find_python_module("sklearn")
+ find_python_module("ot")
+ find_python_module("pybind11")
+@@ -171,16 +170,5 @@ if (WITH_GUDHI_PYTHON)
+ option(WITH_GUDHI_PYTHON_RUNTIME_LIBRARY_DIRS "Build with setting runtime_library_dirs. Useful when setting rpath is not allowed" ON)
+
+ if(PYTHONINTERP_FOUND AND CYTHON_FOUND)
+- if(SPHINX_FOUND)
+- # Documentation generation is available through sphinx
+- find_program( SPHINX_PATH sphinx-build )
+-
+- if(NOT SPHINX_PATH)
+- if(PYTHON_VERSION_MAJOR EQUAL 3)
+- # In Python3, just hack sphinx-build if it does not exist
+- set(SPHINX_PATH "${PYTHON_EXECUTABLE}" "-m" "sphinx.cmd.build")
+- endif(PYTHON_VERSION_MAJOR EQUAL 3)
+- endif(NOT SPHINX_PATH)
+- endif(SPHINX_FOUND)
+ endif(PYTHONINTERP_FOUND AND CYTHON_FOUND)
+ endif (WITH_GUDHI_PYTHON)
diff --git a/debian/patches/0005-Disable-Sphinx.patch b/debian/patches/0005-Disable-Sphinx.patch
deleted file mode 100644
index d741bb9f..00000000
--- a/debian/patches/0005-Disable-Sphinx.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Tue, 21 Jan 2020 10:36:48 +0100
-Subject: Disable Sphinx.
-
----
- src/cmake/modules/GUDHI_third_party_libraries.cmake | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/cmake/modules/GUDHI_third_party_libraries.cmake b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-index 0abe66b..7a418e4 100644
---- a/src/cmake/modules/GUDHI_third_party_libraries.cmake
-+++ b/src/cmake/modules/GUDHI_third_party_libraries.cmake
-@@ -175,7 +175,6 @@ if( PYTHONINTERP_FOUND )
- find_python_module("matplotlib")
- find_python_module("numpy")
- find_python_module("scipy")
-- find_python_module("sphinx")
- find_python_module("sklearn")
- find_python_module("ot")
- find_python_module("pybind11")
diff --git a/debian/patches/0005-Support-Hera-1.0.patch b/debian/patches/0005-Support-Hera-1.0.patch
new file mode 100644
index 00000000..de783cb4
--- /dev/null
+++ b/debian/patches/0005-Support-Hera-1.0.patch
@@ -0,0 +1,66 @@
+From: Gard Spreemann <gspr@nonempty.org>
+Date: Fri, 20 Jan 2023 17:02:04 +0100
+Subject: Support Hera 1.0
+
+Upstream GUDHI now expects Hera's headers to be organized as in Hera
+2.0. This patch restores the old behavior until Hera 2.0 is available
+in Debian.
+---
+ src/Nerve_GIC/include/gudhi/GIC.h | 4 ++--
+ src/cmake/modules/GUDHI_submodules.cmake | 2 +-
+ src/python/gudhi/hera/bottleneck.cc | 2 +-
+ src/python/gudhi/hera/wasserstein.cc | 2 +-
+ 4 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/src/Nerve_GIC/include/gudhi/GIC.h b/src/Nerve_GIC/include/gudhi/GIC.h
+index 047fba6..560f7d6 100644
+--- a/src/Nerve_GIC/include/gudhi/GIC.h
++++ b/src/Nerve_GIC/include/gudhi/GIC.h
+@@ -20,9 +20,9 @@
+ #if __has_include(<CGAL/version.h>)
+ # define GUDHI_GIC_USE_CGAL 1
+ # include <gudhi/Bottleneck.h>
+-#elif __has_include(<hera/bottleneck.h>)
++#elif __has_include(<bottleneck.h>)
+ # define GUDHI_GIC_USE_HERA 1
+-# include <hera/bottleneck.h>
++# include <bottleneck.h>
+ #endif
+
+ #include <gudhi/Debug_utils.h>
+diff --git a/src/cmake/modules/GUDHI_submodules.cmake b/src/cmake/modules/GUDHI_submodules.cmake
+index 9ede852..cec9390 100644
+--- a/src/cmake/modules/GUDHI_submodules.cmake
++++ b/src/cmake/modules/GUDHI_submodules.cmake
+@@ -2,4 +2,4 @@
+ set(HERA_INTERNAL_INCLUDE_DIR ${CMAKE_SOURCE_DIR}/ext/hera/include)
+ set(HERA_INCLUDE_DIR ${HERA_INTERNAL_INCLUDE_DIR} CACHE PATH "Directory where one can find hera/{wasserstein.h,bottleneck.h}")
+ # since everything is cleanly under include/hera/, there is no harm always including it
+-include_directories(${HERA_INCLUDE_DIR})
++include_directories(${HERA_INCLUDE_DIR}/bottleneck ${HERA_INCLUDE_DIR}/wasserstein)
+diff --git a/src/python/gudhi/hera/bottleneck.cc b/src/python/gudhi/hera/bottleneck.cc
+index ec461f7..0cb562c 100644
+--- a/src/python/gudhi/hera/bottleneck.cc
++++ b/src/python/gudhi/hera/bottleneck.cc
+@@ -16,7 +16,7 @@
+ using py::ssize_t;
+ #endif
+
+-#include <hera/bottleneck.h> // Hera
++#include <bottleneck.h> // Hera
+
+ double bottleneck_distance(Dgm d1, Dgm d2, double delta)
+ {
+diff --git a/src/python/gudhi/hera/wasserstein.cc b/src/python/gudhi/hera/wasserstein.cc
+index 3516352..e1bb1d7 100644
+--- a/src/python/gudhi/hera/wasserstein.cc
++++ b/src/python/gudhi/hera/wasserstein.cc
+@@ -16,7 +16,7 @@
+ using py::ssize_t;
+ #endif
+
+-#include <hera/wasserstein.h> // Hera
++#include <wasserstein.h> // Hera
+
+ double wasserstein_distance(
+ Dgm d1, Dgm d2,
diff --git a/debian/patches/0006-Install-Python-module-in-correct-location.patch b/debian/patches/0006-Install-Python-module-in-correct-location.patch
deleted file mode 100644
index e8c23fde..00000000
--- a/debian/patches/0006-Install-Python-module-in-correct-location.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Thu, 26 Sep 2019 13:26:22 +0200
-Subject: Install Python module in correct location.
-
----
- src/python/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index 1a2f18b..94ef78b 100644
---- a/src/python/CMakeLists.txt
-+++ b/src/python/CMakeLists.txt
-@@ -243,7 +243,7 @@ if(PYTHONINTERP_FOUND)
- add_custom_target(python ALL DEPENDS gudhi.so
- COMMENT "Do not forget to add ${CMAKE_CURRENT_BINARY_DIR}/ to your PYTHONPATH before using examples or tests")
-
-- install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/setup.py install)")
-+ install(CODE "execute_process(COMMAND ${PYTHON_EXECUTABLE} setup.py install --root=${CMAKE_SOURCE_DIR}/debian/tmp --single-version-externally-managed --install-layout=deb WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR})")
-
- # Documentation generation is available through sphinx - requires all modules
- # Make it first as sphinx test is by far the longest test which is nice when testing in parallel
diff --git a/debian/patches/0007-Move-towards-reproducible-builds.patch b/debian/patches/0007-Move-towards-reproducible-builds.patch
deleted file mode 100644
index 7e2f01db..00000000
--- a/debian/patches/0007-Move-towards-reproducible-builds.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Tue, 21 Jan 2020 10:39:23 +0100
-Subject: Move towards reproducible builds.
-
-This does not take us all the way there, and probably breaks doctest,
-but since we're not doing Sphinx stuff yet anyway, that is ok for now.
----
- src/python/gudhi/__init__.py.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/python/gudhi/__init__.py.in b/src/python/gudhi/__init__.py.in
-index 79e12fb..991745a 100644
---- a/src/python/gudhi/__init__.py.in
-+++ b/src/python/gudhi/__init__.py.in
-@@ -15,7 +15,7 @@ __copyright__ = "Copyright (C) 2016 Inria"
- __license__ = "https://gudhi.inria.fr/licensing/"
- __version__ = "@GUDHI_VERSION@"
- # This variable is used by doctest to find files
--__root_source_dir__ = "@CMAKE_SOURCE_DIR@"
-+__root_source_dir__ = "."
- __debug_info__ = @GUDHI_PYTHON_DEBUG_INFO@
-
- __all__ = [@GUDHI_PYTHON_MODULES@ @GUDHI_PYTHON_MODULES_EXTRA@]
diff --git a/debian/patches/0008-Don-t-try-to-install-Hera.patch b/debian/patches/0008-Don-t-try-to-install-Hera.patch
deleted file mode 100644
index c498e81a..00000000
--- a/debian/patches/0008-Don-t-try-to-install-Hera.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Thu, 4 Jun 2020 14:36:26 +0200
-Subject: Don't try to install Hera.
-
-We use the system version.
----
- src/cmake/modules/GUDHI_user_version_target.cmake | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/src/cmake/modules/GUDHI_user_version_target.cmake b/src/cmake/modules/GUDHI_user_version_target.cmake
-index 9cf648e..321f49d 100644
---- a/src/cmake/modules/GUDHI_user_version_target.cmake
-+++ b/src/cmake/modules/GUDHI_user_version_target.cmake
-@@ -58,8 +58,6 @@ add_custom_command(TARGET user_version PRE_BUILD COMMAND ${CMAKE_COMMAND} -E
- add_custom_command(TARGET user_version PRE_BUILD COMMAND ${CMAKE_COMMAND} -E
- copy_directory ${CMAKE_SOURCE_DIR}/src/GudhUI ${GUDHI_USER_VERSION_DIR}/GudhUI)
-
--add_custom_command(TARGET user_version PRE_BUILD COMMAND ${CMAKE_COMMAND} -E
-- copy_directory ${CMAKE_SOURCE_DIR}/ext/hera/wasserstein/include ${GUDHI_USER_VERSION_DIR}/ext/hera/wasserstein/include)
-
- set(GUDHI_DIRECTORIES "doc;example;concept;utilities")
-
diff --git a/debian/patches/0009-Keep-POT-optional.patch b/debian/patches/0009-Keep-POT-optional.patch
deleted file mode 100644
index 0324551a..00000000
--- a/debian/patches/0009-Keep-POT-optional.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Thu, 4 Jun 2020 14:37:55 +0200
-Subject: Keep POT optional.
-
----
- src/python/gudhi/wasserstein/barycenter.py | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/src/python/gudhi/wasserstein/barycenter.py b/src/python/gudhi/wasserstein/barycenter.py
-index d67bcde..e376ecc 100644
---- a/src/python/gudhi/wasserstein/barycenter.py
-+++ b/src/python/gudhi/wasserstein/barycenter.py
-@@ -8,7 +8,10 @@
- # - YYYY/MM Author: Description of the modification
-
-
--import ot
-+try:
-+ import ot
-+except ImportError:
-+ print("POT (Python Optimal Transport) package is not installed.")
- import numpy as np
- import scipy.spatial.distance as sc
-
diff --git a/debian/patches/0010-Work-around-963955.patch b/debian/patches/0010-Work-around-963955.patch
deleted file mode 100644
index 76eeb500..00000000
--- a/debian/patches/0010-Work-around-963955.patch
+++ /dev/null
@@ -1,120 +0,0 @@
-From: Gard Spreemann <gspr@nonempty.org>
-Date: Mon, 29 Jun 2020 13:37:10 +0200
-Subject: Work around #963955.
-
-This works around a bug in Qt 5.14.x causing any software using TBB
-together with Qt to FTBFS. It is fixed upstream in 5.15.1.
----
- src/Bitmap_cubical_complex/include/gudhi/Bitmap_cubical_complex.h | 2 ++
- src/Bottleneck_distance/include/gudhi/Persistence_graph.h | 2 ++
- src/Hasse_complex/include/gudhi/Hasse_complex.h | 2 ++
- src/Nerve_GIC/include/gudhi/GIC.h | 2 ++
- src/Simplex_tree/include/gudhi/Simplex_tree.h | 2 ++
- src/Tangential_complex/benchmark/benchmark_tc.cpp | 2 ++
- src/Tangential_complex/include/gudhi/Tangential_complex.h | 2 ++
- 7 files changed, 14 insertions(+)
-
-diff --git a/src/Bitmap_cubical_complex/include/gudhi/Bitmap_cubical_complex.h b/src/Bitmap_cubical_complex/include/gudhi/Bitmap_cubical_complex.h
-index aa255ec..ae29f6c 100644
---- a/src/Bitmap_cubical_complex/include/gudhi/Bitmap_cubical_complex.h
-+++ b/src/Bitmap_cubical_complex/include/gudhi/Bitmap_cubical_complex.h
-@@ -15,8 +15,10 @@
- #include <gudhi/Bitmap_cubical_complex_periodic_boundary_conditions_base.h>
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/parallel_sort.h>
- #endif
-+#endif
-
- #include <limits>
- #include <utility> // for pair<>
-diff --git a/src/Bottleneck_distance/include/gudhi/Persistence_graph.h b/src/Bottleneck_distance/include/gudhi/Persistence_graph.h
-index e1e3522..b865681 100644
---- a/src/Bottleneck_distance/include/gudhi/Persistence_graph.h
-+++ b/src/Bottleneck_distance/include/gudhi/Persistence_graph.h
-@@ -14,8 +14,10 @@
- #include <gudhi/Internal_point.h>
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/parallel_sort.h>
- #endif
-+#endif
-
- #include <vector>
- #include <algorithm>
-diff --git a/src/Hasse_complex/include/gudhi/Hasse_complex.h b/src/Hasse_complex/include/gudhi/Hasse_complex.h
-index 8ce8c36..4842cc2 100644
---- a/src/Hasse_complex/include/gudhi/Hasse_complex.h
-+++ b/src/Hasse_complex/include/gudhi/Hasse_complex.h
-@@ -21,8 +21,10 @@
- #include <limits> // for infinity value
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/parallel_for.h>
- #endif
-+#endif
-
- namespace Gudhi {
-
-diff --git a/src/Nerve_GIC/include/gudhi/GIC.h b/src/Nerve_GIC/include/gudhi/GIC.h
-index 1b1f932..653501c 100644
---- a/src/Nerve_GIC/include/gudhi/GIC.h
-+++ b/src/Nerve_GIC/include/gudhi/GIC.h
-@@ -13,7 +13,9 @@
- #define GIC_H_
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/parallel_for.h>
-+#endif
- #include <mutex>
- #endif
-
-diff --git a/src/Simplex_tree/include/gudhi/Simplex_tree.h b/src/Simplex_tree/include/gudhi/Simplex_tree.h
-index 889dbd0..ac64650 100644
---- a/src/Simplex_tree/include/gudhi/Simplex_tree.h
-+++ b/src/Simplex_tree/include/gudhi/Simplex_tree.h
-@@ -27,8 +27,10 @@
- #include <boost/container/static_vector.hpp>
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/parallel_sort.h>
- #endif
-+#endif
-
- #include <utility>
- #include <vector>
-diff --git a/src/Tangential_complex/benchmark/benchmark_tc.cpp b/src/Tangential_complex/benchmark/benchmark_tc.cpp
-index e3b2a04..3e5227a 100644
---- a/src/Tangential_complex/benchmark/benchmark_tc.cpp
-+++ b/src/Tangential_complex/benchmark/benchmark_tc.cpp
-@@ -48,8 +48,10 @@ const std::size_t ONLY_LOAD_THE_FIRST_N_POINTS = 20000000;
- #include <cmath> // for std::sqrt
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/task_scheduler_init.h>
- #endif
-+#endif
- #include "XML_exporter.h"
- #include "RIB_exporter.h"
- #define GUDHI_TC_EXPORT_PERFORMANCE_DATA
-diff --git a/src/Tangential_complex/include/gudhi/Tangential_complex.h b/src/Tangential_complex/include/gudhi/Tangential_complex.h
-index f007bdd..e49261e 100644
---- a/src/Tangential_complex/include/gudhi/Tangential_complex.h
-+++ b/src/Tangential_complex/include/gudhi/Tangential_complex.h
-@@ -58,8 +58,10 @@
- #include <cstddef> // for std::size_t
-
- #ifdef GUDHI_USE_TBB
-+#ifndef Q_MOC_RUN
- #include <tbb/parallel_for.h>
- #include <tbb/combinable.h>
-+#endif
- #include <mutex>
- #endif
-
diff --git a/debian/patches/series b/debian/patches/series
index 80880a58..0019c6f4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,10 +1,5 @@
0001-Disable-tests-that-use-DFSG-deleted-data-files.patch
0002-Use-system-MathJax.patch
-0003-Force-linking-against-libatomic-for-parts-that-use-T.patch
-0004-Offline-header-for-docs.patch
-0005-Disable-Sphinx.patch
-0006-Install-Python-module-in-correct-location.patch
-0007-Move-towards-reproducible-builds.patch
-0008-Don-t-try-to-install-Hera.patch
-0009-Keep-POT-optional.patch
-0010-Work-around-963955.patch
+0003-Offline-header-for-docs.patch
+0004-Disable-Sphinx.patch
+0005-Support-Hera-1.0.patch