summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules13
1 files changed, 11 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 182165f3..c7a9cbef 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,13 +11,22 @@ PY3VERS:=$(shell py3versions -vs)
DEFAULT_PY3VER=$(shell py3versions -vd)
REMAINING_PY3VERS:=$(filter-out $(DEFAULT_PY3VER), $(PY3VERS))
-DHFLAGS+=--buildsystem=cmake --no-parallel
+DHFLAGS+=--buildsystem=cmake
+
+# To fix #945226, we turn off parallel builds everywhere, except if
+# someone explicitly wants them enabled by setting the enivronment
+# variable ALLOW_PARALLEL.
+ifeq (, $(ALLOW_PARALLEL))
+ DHFLAGS+=--no-parallel
+endif
# The buildds run out of memory on some architectures. On those, we
# force non-parallel building.
ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mipsel m68k powerpcspe x32))
export DEB_CXXFLAGS_MAINT_APPEND = --param ggc-min-expand=5
- DHFLAGS+=--no-parallel
+# We have disabled parallel builds in general now. Consider disabling
+# for certain architectures if it's reenabled globally.
+# DHFLAGS+=--no-parallel
endif
# Disable tests on i386 due to rounding problem in some. See upstream GitHub issue #118.