summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules5
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 5df41189..57c37786 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
gudhi (3.0.0+dfsg-3) UNRELEASED; urgency=medium
- * Disable build-time tests on s390x. See #943384.
+ * Disable build-time tests on i386 and s390x.
-- Gard Spreemann <gspr@nonempty.org> Thu, 24 Oct 2019 09:34:05 +0200
diff --git a/debian/rules b/debian/rules
index 889ba625..decadfde 100755
--- a/debian/rules
+++ b/debian/rules
@@ -20,8 +20,9 @@ ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mi
DHFLAGS+=--no-parallel
endif
+# Disable tests on i386 due to rounding problem in some. See upstream GitHub issue #118.
# Disable tests on s390x, as a few are broken. See #943384.
-ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),s390x))
+ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 s390x))
export DEB_BUILD_MAINT_OPTIONS := $(DEB_BUILD_MAINT_OPTIONS) nocheck
endif
@@ -54,7 +55,7 @@ override_dh_auto_test-indep:
override_dh_auto_test-arch:
# I believe this should be handled automatically by dh_auto_test,
# but see #901678.
-ifeq (, $(findstring nocheck,$(DEB_BUILD_MAINT_OPTIONS)))
+ifeq (, $(filter nocheck,$(DEB_BUILD_MAINT_OPTIONS)))
dh_auto_test $(DHFLAGS) --no-parallel --builddirectory=build
for py3ver in $(REMAINING_PY3VERS) ; do \
dh_auto_test $(DHFLAGS) --no-parallel --builddirectory=build$$py3ver ; \