summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index decadfde..759a7ceb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,14 +15,14 @@ DHFLAGS+=--buildsystem=cmake
# The buildds run out of memory on some architectures. On those, we
# force non-parallel building.
-ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mipsel m68k powerpcspe))
+ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 mips mipsel m68k powerpcspe x32))
export DEB_CXXFLAGS_MAINT_APPEND = --param ggc-min-expand=5
DHFLAGS+=--no-parallel
endif
# Disable tests on i386 due to rounding problem in some. See upstream GitHub issue #118.
# Disable tests on s390x, as a few are broken. See #943384.
-ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 s390x))
+ifneq (, $(filter $(shell dpkg-architecture --query DEB_BUILD_ARCH),i386 s390x x32))
export DEB_BUILD_MAINT_OPTIONS := $(DEB_BUILD_MAINT_OPTIONS) nocheck
endif