summaryrefslogtreecommitdiff
path: root/example/Persistence_representations
diff options
context:
space:
mode:
Diffstat (limited to 'example/Persistence_representations')
-rw-r--r--example/Persistence_representations/CMakeLists.txt28
-rw-r--r--example/Persistence_representations/persistence_heat_maps.cpp80
-rw-r--r--example/Persistence_representations/persistence_intervals.cpp89
-rw-r--r--example/Persistence_representations/persistence_landscape.cpp86
-rw-r--r--example/Persistence_representations/persistence_landscape_on_grid.cpp82
-rw-r--r--example/Persistence_representations/persistence_vectors.cpp74
6 files changed, 0 insertions, 439 deletions
diff --git a/example/Persistence_representations/CMakeLists.txt b/example/Persistence_representations/CMakeLists.txt
deleted file mode 100644
index 33558df3..00000000
--- a/example/Persistence_representations/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-project(Persistence_representations_example)
-
-add_executable ( Persistence_representations_example_landscape_on_grid persistence_landscape_on_grid.cpp )
-add_test(NAME Persistence_representations_example_landscape_on_grid
- COMMAND $<TARGET_FILE:Persistence_representations_example_landscape_on_grid>)
-install(TARGETS Persistence_representations_example_landscape_on_grid DESTINATION bin)
-
-add_executable ( Persistence_representations_example_landscape persistence_landscape.cpp )
-add_test(NAME Persistence_representations_example_landscape
- COMMAND $<TARGET_FILE:Persistence_representations_example_landscape>)
-install(TARGETS Persistence_representations_example_landscape DESTINATION bin)
-
-add_executable ( Persistence_representations_example_intervals persistence_intervals.cpp )
-add_test(NAME Persistence_representations_example_intervals
- COMMAND $<TARGET_FILE:Persistence_representations_example_intervals>
- "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers")
-install(TARGETS Persistence_representations_example_intervals DESTINATION bin)
-
-add_executable ( Persistence_representations_example_vectors persistence_vectors.cpp )
-add_test(NAME Persistence_representations_example_vectors
- COMMAND $<TARGET_FILE:Persistence_representations_example_vectors>)
-install(TARGETS Persistence_representations_example_vectors DESTINATION bin)
-
-add_executable ( Persistence_representations_example_heat_maps persistence_heat_maps.cpp )
-add_test(NAME Persistence_representations_example_heat_maps
- COMMAND $<TARGET_FILE:Persistence_representations_example_heat_maps>)
-install(TARGETS Persistence_representations_example_heat_maps DESTINATION bin)
-
diff --git a/example/Persistence_representations/persistence_heat_maps.cpp b/example/Persistence_representations/persistence_heat_maps.cpp
deleted file mode 100644
index 323b57e9..00000000
--- a/example/Persistence_representations/persistence_heat_maps.cpp
+++ /dev/null
@@ -1,80 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <vector>
-#include <utility>
-
-using constant_scaling_function = Gudhi::Persistence_representations::constant_scaling_function;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<constant_scaling_function>;
-
-int main(int argc, char** argv) {
- // create two simple vectors with birth--death pairs:
-
- std::vector<std::pair<double, double> > persistence1;
- std::vector<std::pair<double, double> > persistence2;
-
- persistence1.push_back(std::make_pair(1, 2));
- persistence1.push_back(std::make_pair(6, 8));
- persistence1.push_back(std::make_pair(0, 4));
- persistence1.push_back(std::make_pair(3, 8));
-
- persistence2.push_back(std::make_pair(2, 9));
- persistence2.push_back(std::make_pair(1, 6));
- persistence2.push_back(std::make_pair(3, 5));
- persistence2.push_back(std::make_pair(6, 10));
-
- // over here we define a function we sill put on a top on every birth--death pair in the persistence interval. It can
- // be anything. Over here we will use standard Gaussian
- std::vector<std::vector<double> > filter = Gudhi::Persistence_representations::create_Gaussian_filter(5, 1);
-
- // creating two heat maps.
- Persistence_heat_maps hm1(persistence1, filter, false, 20, 0, 11);
- Persistence_heat_maps hm2(persistence2, filter, false, 20, 0, 11);
-
- std::vector<Persistence_heat_maps*> vector_of_maps;
- vector_of_maps.push_back(&hm1);
- vector_of_maps.push_back(&hm2);
-
- // compute median/mean of a vector of heat maps:
- Persistence_heat_maps mean;
- mean.compute_mean(vector_of_maps);
- Persistence_heat_maps median;
- median.compute_median(vector_of_maps);
-
- // to compute L^1 distance between hm1 and hm2:
- std::cout << "The L^1 distance is : " << hm1.distance(hm2, 1) << std::endl;
-
- // to average of hm1 and hm2:
- std::vector<Persistence_heat_maps*> to_average;
- to_average.push_back(&hm1);
- to_average.push_back(&hm2);
- Persistence_heat_maps av;
- av.compute_average(to_average);
-
- // to compute scalar product of hm1 and hm2:
- std::cout << "Scalar product is : " << hm1.compute_scalar_product(hm2) << std::endl;
-
- return 0;
-}
diff --git a/example/Persistence_representations/persistence_intervals.cpp b/example/Persistence_representations/persistence_intervals.cpp
deleted file mode 100644
index b5dcf25c..00000000
--- a/example/Persistence_representations/persistence_intervals.cpp
+++ /dev/null
@@ -1,89 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_intervals.h>
-
-#include <iostream>
-#include <utility>
-#include <vector>
-
-using Persistence_intervals = Gudhi::Persistence_representations::Persistence_intervals;
-
-int main(int argc, char** argv) {
- if (argc != 2) {
- std::cout << "To run this program, please provide the name of a file with persistence diagram \n";
- return 1;
- }
-
- Persistence_intervals p(argv[1]);
- std::pair<double, double> min_max_ = p.get_x_range();
- std::cout << "Birth-death range : " << min_max_.first << " " << min_max_.second << std::endl;
-
- std::vector<double> dominant_ten_intervals_length = p.length_of_dominant_intervals(10);
- std::cout << "Length of ten dominant intervals : " << std::endl;
- for (size_t i = 0; i != dominant_ten_intervals_length.size(); ++i) {
- std::cout << dominant_ten_intervals_length[i] << std::endl;
- }
-
- std::vector<std::pair<double, double> > ten_dominant_intervals = p.dominant_intervals(10);
- std::cout << "Here are the dominant intervals : " << std::endl;
- for (size_t i = 0; i != ten_dominant_intervals.size(); ++i) {
- std::cout << "( " << ten_dominant_intervals[i].first << "," << ten_dominant_intervals[i].second << std::endl;
- }
-
- std::vector<size_t> histogram = p.histogram_of_lengths(10);
- std::cout << "Here is the histogram of barcode's length : " << std::endl;
- for (size_t i = 0; i != histogram.size(); ++i) {
- std::cout << histogram[i] << " ";
- }
- std::cout << std::endl;
-
- std::vector<size_t> cumulative_histogram = p.cumulative_histogram_of_lengths(10);
- std::cout << "Cumulative histogram : " << std::endl;
- for (size_t i = 0; i != cumulative_histogram.size(); ++i) {
- std::cout << cumulative_histogram[i] << " ";
- }
- std::cout << std::endl;
-
- std::vector<double> char_funct_diag = p.characteristic_function_of_diagram(min_max_.first, min_max_.second);
- std::cout << "Characteristic function of diagram : " << std::endl;
- for (size_t i = 0; i != char_funct_diag.size(); ++i) {
- std::cout << char_funct_diag[i] << " ";
- }
- std::cout << std::endl;
-
- std::vector<double> cumul_char_funct_diag =
- p.cumulative_characteristic_function_of_diagram(min_max_.first, min_max_.second);
- std::cout << "Cumulative characteristic function of diagram : " << std::endl;
- for (size_t i = 0; i != cumul_char_funct_diag.size(); ++i) {
- std::cout << cumul_char_funct_diag[i] << " ";
- }
- std::cout << std::endl;
-
- std::cout << "Persistence Betti numbers \n";
- std::vector<std::pair<double, size_t> > pbns = p.compute_persistent_betti_numbers();
- for (size_t i = 0; i != pbns.size(); ++i) {
- std::cout << pbns[i].first << " " << pbns[i].second << std::endl;
- }
-
- return 0;
-}
diff --git a/example/Persistence_representations/persistence_landscape.cpp b/example/Persistence_representations/persistence_landscape.cpp
deleted file mode 100644
index 27542cf7..00000000
--- a/example/Persistence_representations/persistence_landscape.cpp
+++ /dev/null
@@ -1,86 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_landscape.h>
-
-#include <iostream>
-#include <vector>
-#include <utility>
-
-using Persistence_landscape = Gudhi::Persistence_representations::Persistence_landscape;
-
-int main(int argc, char** argv) {
- // create two simple vectors with birth--death pairs:
-
- std::vector<std::pair<double, double> > persistence1;
- std::vector<std::pair<double, double> > persistence2;
-
- persistence1.push_back(std::make_pair(1, 2));
- persistence1.push_back(std::make_pair(6, 8));
- persistence1.push_back(std::make_pair(0, 4));
- persistence1.push_back(std::make_pair(3, 8));
-
- persistence2.push_back(std::make_pair(2, 9));
- persistence2.push_back(std::make_pair(1, 6));
- persistence2.push_back(std::make_pair(3, 5));
- persistence2.push_back(std::make_pair(6, 10));
-
- // create two persistence landscapes based on persistence1 and persistence2:
- Persistence_landscape l1(persistence1);
- Persistence_landscape l2(persistence2);
-
- // This is how to compute integral of landscapes:
- std::cout << "Integral of the first landscape : " << l1.compute_integral_of_landscape() << std::endl;
- std::cout << "Integral of the second landscape : " << l2.compute_integral_of_landscape() << std::endl;
-
- // And here how to write landscapes to stream:
- std::cout << "l1 : " << l1 << std::endl;
- std::cout << "l2 : " << l2 << std::endl;
-
- // Arithmetic operations on landscapes:
- Persistence_landscape sum = l1 + l2;
- std::cout << "sum : " << sum << std::endl;
-
- // here are the maxima of the functions:
- std::cout << "Maximum of l1 : " << l1.compute_maximum() << std::endl;
- std::cout << "Maximum of l2 : " << l2.compute_maximum() << std::endl;
-
- // here are the norms of landscapes:
- std::cout << "L^1 Norm of l1 : " << l1.compute_norm_of_landscape(1.) << std::endl;
- std::cout << "L^1 Norm of l2 : " << l2.compute_norm_of_landscape(1.) << std::endl;
-
- // here is the average of landscapes:
- Persistence_landscape average;
- average.compute_average({&l1, &l2});
- std::cout << "average : " << average << std::endl;
-
- // here is the distance of landscapes:
- std::cout << "Distance : " << l1.distance(l2) << std::endl;
-
- // here is the scalar product of landscapes:
- std::cout << "Scalar product : " << l1.compute_scalar_product(l2) << std::endl;
-
- // here is how to create a file which is suitable for visualization via gnuplot:
- average.plot("average_landscape");
-
- return 0;
-}
diff --git a/example/Persistence_representations/persistence_landscape_on_grid.cpp b/example/Persistence_representations/persistence_landscape_on_grid.cpp
deleted file mode 100644
index 0f471a67..00000000
--- a/example/Persistence_representations/persistence_landscape_on_grid.cpp
+++ /dev/null
@@ -1,82 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_landscape_on_grid.h>
-
-#include <iostream>
-#include <utility>
-#include <vector>
-
-using Persistence_landscape_on_grid = Gudhi::Persistence_representations::Persistence_landscape_on_grid;
-
-int main(int argc, char** argv) {
- // create two simple vectors with birth--death pairs:
-
- std::vector<std::pair<double, double> > persistence1;
- std::vector<std::pair<double, double> > persistence2;
-
- persistence1.push_back(std::make_pair(1, 2));
- persistence1.push_back(std::make_pair(6, 8));
- persistence1.push_back(std::make_pair(0, 4));
- persistence1.push_back(std::make_pair(3, 8));
-
- persistence2.push_back(std::make_pair(2, 9));
- persistence2.push_back(std::make_pair(1, 6));
- persistence2.push_back(std::make_pair(3, 5));
- persistence2.push_back(std::make_pair(6, 10));
-
- // create two persistence landscapes based on persistence1 and persistence2:
- Persistence_landscape_on_grid l1(persistence1, 0, 11, 20);
- Persistence_landscape_on_grid l2(persistence2, 0, 11, 20);
-
- // This is how to compute integral of landscapes:
- std::cout << "Integral of the first landscape : " << l1.compute_integral_of_landscape() << std::endl;
- std::cout << "Integral of the second landscape : " << l2.compute_integral_of_landscape() << std::endl;
-
- // And here how to write landscapes to stream:
- std::cout << "l1 : " << l1 << std::endl;
- std::cout << "l2 : " << l2 << std::endl;
-
- // here are the maxima of the functions:
- std::cout << "Maximum of l1 : " << l1.compute_maximum() << std::endl;
- std::cout << "Maximum of l2 : " << l2.compute_maximum() << std::endl;
-
- // here are the norms of landscapes:
- std::cout << "L^1 Norm of l1 : " << l1.compute_norm_of_landscape(1.) << std::endl;
- std::cout << "L^1 Norm of l2 : " << l2.compute_norm_of_landscape(1.) << std::endl;
-
- // here is the average of landscapes:
- Persistence_landscape_on_grid average;
- average.compute_average({&l1, &l2});
- std::cout << "average : " << average << std::endl;
-
- // here is the distance of landscapes:
- std::cout << "Distance : " << l1.distance(l2) << std::endl;
-
- // here is the scalar product of landscapes:
- std::cout << "Scalar product : " << l1.compute_scalar_product(l2) << std::endl;
-
- // here is how to create a file which is suitable for visualization via gnuplot:
- average.plot("average_landscape");
-
- return 0;
-}
diff --git a/example/Persistence_representations/persistence_vectors.cpp b/example/Persistence_representations/persistence_vectors.cpp
deleted file mode 100644
index 072e530d..00000000
--- a/example/Persistence_representations/persistence_vectors.cpp
+++ /dev/null
@@ -1,74 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_vectors.h>
-
-#include <iostream>
-#include <vector>
-#include <cmath>
-#include <iomanip>
-#include <limits>
-#include <utility>
-
-using Vector_distances_in_diagram =
- Gudhi::Persistence_representations::Vector_distances_in_diagram<Gudhi::Euclidean_distance>;
-
-int main(int argc, char** argv) {
- // create two simple vectors with birth--death pairs:
-
- std::vector<std::pair<double, double> > persistence1;
- std::vector<std::pair<double, double> > persistence2;
-
- persistence1.push_back(std::make_pair(1, 2));
- persistence1.push_back(std::make_pair(6, 8));
- persistence1.push_back(std::make_pair(0, 4));
- persistence1.push_back(std::make_pair(3, 8));
-
- persistence2.push_back(std::make_pair(2, 9));
- persistence2.push_back(std::make_pair(1, 6));
- persistence2.push_back(std::make_pair(3, 5));
- persistence2.push_back(std::make_pair(6, 10));
-
- // create two persistence vectors based on persistence1 and persistence2:
- Vector_distances_in_diagram v1(persistence1, std::numeric_limits<size_t>::max());
- Vector_distances_in_diagram v2(persistence2, std::numeric_limits<size_t>::max());
-
- // writing to a stream:
- std::cout << "v1 : " << v1 << std::endl;
- std::cout << "v2 : " << v2 << std::endl;
-
- // averages:
- Vector_distances_in_diagram average;
- average.compute_average({&v1, &v2});
- std::cout << "Average : " << average << std::endl;
-
- // computations of distances:
- std::cout << "l^1 distance : " << v1.distance(v2) << std::endl;
-
- // computations of scalar product:
- std::cout << "Scalar product of l1 and l2 : " << v1.compute_scalar_product(v2) << std::endl;
-
- // create a file with a gnuplot script:
- v1.plot("plot_of_vector_representation");
-
- return 0;
-}