summaryrefslogtreecommitdiff
path: root/example/Rips_complex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/Rips_complex/CMakeLists.txt')
-rw-r--r--example/Rips_complex/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/example/Rips_complex/CMakeLists.txt b/example/Rips_complex/CMakeLists.txt
index 8aee79e2..2940f164 100644
--- a/example/Rips_complex/CMakeLists.txt
+++ b/example/Rips_complex/CMakeLists.txt
@@ -3,17 +3,13 @@ project(Rips_complex_examples)
# Point cloud
add_executable ( Rips_complex_example_from_off example_rips_complex_from_off_file.cpp )
-target_link_libraries(Rips_complex_example_from_off ${Boost_SYSTEM_LIBRARY})
add_executable ( Rips_complex_example_one_skeleton_from_points example_one_skeleton_rips_from_points.cpp )
-target_link_libraries(Rips_complex_example_one_skeleton_from_points ${Boost_SYSTEM_LIBRARY})
# Distance matrix
add_executable ( Rips_complex_example_one_skeleton_from_distance_matrix example_one_skeleton_rips_from_distance_matrix.cpp )
-target_link_libraries(Rips_complex_example_one_skeleton_from_distance_matrix ${Boost_SYSTEM_LIBRARY})
add_executable ( Rips_complex_example_from_csv_distance_matrix example_rips_complex_from_csv_distance_matrix_file.cpp )
-target_link_libraries(Rips_complex_example_from_csv_distance_matrix ${Boost_SYSTEM_LIBRARY})
if (TBB_FOUND)
target_link_libraries(Rips_complex_example_from_off ${TBB_LIBRARIES})
@@ -56,3 +52,8 @@ if (DIFF_PATH)
${CMAKE_CURRENT_BINARY_DIR}/ripscsvreader_result_12_3.txt
${CMAKE_CURRENT_BINARY_DIR}/full_skeleton_rips_for_doc.txt)
endif()
+
+install(TARGETS Rips_complex_example_from_off DESTINATION bin)
+install(TARGETS Rips_complex_example_one_skeleton_from_points DESTINATION bin)
+install(TARGETS Rips_complex_example_one_skeleton_from_distance_matrix DESTINATION bin)
+install(TARGETS Rips_complex_example_from_csv_distance_matrix DESTINATION bin)