summaryrefslogtreecommitdiff
path: root/example/Simplex_tree/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/Simplex_tree/CMakeLists.txt')
-rw-r--r--example/Simplex_tree/CMakeLists.txt54
1 files changed, 0 insertions, 54 deletions
diff --git a/example/Simplex_tree/CMakeLists.txt b/example/Simplex_tree/CMakeLists.txt
deleted file mode 100644
index 857e8518..00000000
--- a/example/Simplex_tree/CMakeLists.txt
+++ /dev/null
@@ -1,54 +0,0 @@
-project(Simplex_tree_examples)
-
-add_executable ( Simplex_tree_example_from_cliques_of_graph simplex_tree_from_cliques_of_graph.cpp )
-if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_from_cliques_of_graph ${TBB_LIBRARIES})
-endif()
-add_test(NAME Simplex_tree_example_from_cliques_of_graph_2 COMMAND $<TARGET_FILE:Simplex_tree_example_from_cliques_of_graph>
- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/Klein_bottle_complex.fsc" "2")
-add_test(NAME Simplex_tree_example_from_cliques_of_graph_3 COMMAND $<TARGET_FILE:Simplex_tree_example_from_cliques_of_graph>
- "${CMAKE_SOURCE_DIR}/data/filtered_simplicial_complex/Klein_bottle_complex.fsc" "3")
-
-add_executable ( Simplex_tree_example_simple_simplex_tree simple_simplex_tree.cpp )
-if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_simple_simplex_tree ${TBB_LIBRARIES})
-endif()
-add_test(NAME Simplex_tree_example_simple_simplex_tree COMMAND $<TARGET_FILE:Simplex_tree_example_simple_simplex_tree>)
-
-add_executable ( Simplex_tree_example_mini_simplex_tree mini_simplex_tree.cpp )
-add_test(NAME Simplex_tree_example_mini_simplex_tree COMMAND $<TARGET_FILE:Simplex_tree_example_mini_simplex_tree>)
-
-install(TARGETS Simplex_tree_example_from_cliques_of_graph DESTINATION bin)
-install(TARGETS Simplex_tree_example_simple_simplex_tree DESTINATION bin)
-install(TARGETS Simplex_tree_example_mini_simplex_tree DESTINATION bin)
-
-# An example with Simplex-tree using CGAL alpha_shapes_3
-if(GMP_FOUND AND CGAL_FOUND)
- add_executable ( Simplex_tree_example_alpha_shapes_3_from_off example_alpha_shapes_3_simplex_tree_from_off_file.cpp )
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${GMP_LIBRARIES} ${CGAL_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_alpha_shapes_3_from_off ${TBB_LIBRARIES})
- endif()
- add_test(NAME Simplex_tree_example_alpha_shapes_3_from_off COMMAND $<TARGET_FILE:Simplex_tree_example_alpha_shapes_3_from_off>
- "${CMAKE_SOURCE_DIR}/data/points/bunny_5000.off")
-
- install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
-
- add_executable ( Simplex_tree_example_cech_complex_cgal_mini_sphere_3d cech_complex_cgal_mini_sphere_3d.cpp )
- target_link_libraries(Simplex_tree_example_cech_complex_cgal_mini_sphere_3d ${Boost_PROGRAM_OPTIONS_LIBRARY} ${CGAL_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_cech_complex_cgal_mini_sphere_3d ${TBB_LIBRARIES})
- endif()
- add_test(NAME Simplex_tree_example_cech_complex_cgal_mini_sphere_3d COMMAND $<TARGET_FILE:Simplex_tree_example_cech_complex_cgal_mini_sphere_3d>
- "${CMAKE_SOURCE_DIR}/data/points/tore3D_300.off" -r 0.3 -d 3)
-
- install(TARGETS Simplex_tree_example_alpha_shapes_3_from_off DESTINATION bin)
-endif()
-
-add_executable ( Simplex_tree_example_graph_expansion_with_blocker graph_expansion_with_blocker.cpp )
-if (TBB_FOUND)
- target_link_libraries(Simplex_tree_example_graph_expansion_with_blocker ${TBB_LIBRARIES})
-endif()
-add_test(NAME Simplex_tree_example_graph_expansion_with_blocker COMMAND $<TARGET_FILE:Simplex_tree_example_graph_expansion_with_blocker>)
-
-install(TARGETS Simplex_tree_example_graph_expansion_with_blocker DESTINATION bin)