summaryrefslogtreecommitdiff
path: root/example/Subsampling/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/Subsampling/CMakeLists.txt')
-rw-r--r--example/Subsampling/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/example/Subsampling/CMakeLists.txt b/example/Subsampling/CMakeLists.txt
new file mode 100644
index 00000000..71b8d2e8
--- /dev/null
+++ b/example/Subsampling/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 2.6)
+project(Subsampling_examples)
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ add_executable(Subsampling_example_pick_n_random_points example_pick_n_random_points.cpp)
+ add_executable(Subsampling_example_choose_n_farthest_points example_choose_n_farthest_points.cpp)
+ add_executable(Subsampling_example_custom_kernel example_custom_kernel.cpp)
+ add_executable(Subsampling_example_sparsify_point_set example_sparsify_point_set.cpp)
+ target_link_libraries(Subsampling_example_sparsify_point_set ${CGAL_LIBRARY})
+
+ add_test(NAME Subsampling_example_pick_n_random_points
+ COMMAND $<TARGET_FILE:Subsampling_example_pick_n_random_points>)
+ add_test(NAME Subsampling_example_choose_n_farthest_points
+ COMMAND $<TARGET_FILE:Subsampling_example_choose_n_farthest_points>)
+ add_test(NAME Subsampling_example_sparsify_point_set
+ COMMAND $<TARGET_FILE:Subsampling_example_sparsify_point_set>)
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)