summaryrefslogtreecommitdiff
path: root/example/Subsampling/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/Subsampling/CMakeLists.txt')
-rw-r--r--example/Subsampling/CMakeLists.txt22
1 files changed, 0 insertions, 22 deletions
diff --git a/example/Subsampling/CMakeLists.txt b/example/Subsampling/CMakeLists.txt
deleted file mode 100644
index f26d107f..00000000
--- a/example/Subsampling/CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-project(Subsampling_examples)
-
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable(Subsampling_example_pick_n_random_points example_pick_n_random_points.cpp)
- add_executable(Subsampling_example_choose_n_farthest_points example_choose_n_farthest_points.cpp)
- add_executable(Subsampling_example_custom_kernel example_custom_kernel.cpp)
- add_executable(Subsampling_example_sparsify_point_set example_sparsify_point_set.cpp)
- target_link_libraries(Subsampling_example_sparsify_point_set ${CGAL_LIBRARY})
-
- add_test(NAME Subsampling_example_pick_n_random_points
- COMMAND $<TARGET_FILE:Subsampling_example_pick_n_random_points>)
- add_test(NAME Subsampling_example_choose_n_farthest_points
- COMMAND $<TARGET_FILE:Subsampling_example_choose_n_farthest_points>)
- add_test(NAME Subsampling_example_sparsify_point_set
- COMMAND $<TARGET_FILE:Subsampling_example_sparsify_point_set>)
-
- install(TARGETS Subsampling_example_pick_n_random_points DESTINATION bin)
- install(TARGETS Subsampling_example_choose_n_farthest_points DESTINATION bin)
- install(TARGETS Subsampling_example_custom_kernel DESTINATION bin)
- install(TARGETS Subsampling_example_sparsify_point_set DESTINATION bin)
-
-endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)