summaryrefslogtreecommitdiff
path: root/example/Tangential_complex
diff options
context:
space:
mode:
Diffstat (limited to 'example/Tangential_complex')
-rw-r--r--example/Tangential_complex/CMakeLists.txt20
-rw-r--r--example/Tangential_complex/example_basic.cpp46
-rw-r--r--example/Tangential_complex/example_with_perturb.cpp53
3 files changed, 0 insertions, 119 deletions
diff --git a/example/Tangential_complex/CMakeLists.txt b/example/Tangential_complex/CMakeLists.txt
deleted file mode 100644
index af0dac51..00000000
--- a/example/Tangential_complex/CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
-project(Tangential_complex_examples)
-
-if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
- add_executable( Tangential_complex_example_basic example_basic.cpp )
- target_link_libraries(Tangential_complex_example_basic ${CGAL_LIBRARY})
- add_executable( Tangential_complex_example_with_perturb example_with_perturb.cpp )
- target_link_libraries(Tangential_complex_example_with_perturb ${CGAL_LIBRARY})
- if (TBB_FOUND)
- target_link_libraries(Tangential_complex_example_basic ${TBB_LIBRARIES})
- target_link_libraries(Tangential_complex_example_with_perturb ${TBB_LIBRARIES})
- endif(TBB_FOUND)
-
- add_test(NAME Tangential_complex_example_basic
- COMMAND $<TARGET_FILE:Tangential_complex_example_basic>)
- add_test(NAME Tangential_complex_example_with_perturb
- COMMAND $<TARGET_FILE:Tangential_complex_example_with_perturb>)
-
- install(TARGETS Tangential_complex_example_basic DESTINATION bin)
- install(TARGETS Tangential_complex_example_with_perturb DESTINATION bin)
-endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
diff --git a/example/Tangential_complex/example_basic.cpp b/example/Tangential_complex/example_basic.cpp
deleted file mode 100644
index 4f2b859e..00000000
--- a/example/Tangential_complex/example_basic.cpp
+++ /dev/null
@@ -1,46 +0,0 @@
-#include <gudhi/Tangential_complex.h>
-#include <gudhi/sparsify_point_set.h>
-
-#include <CGAL/Epick_d.h>
-#include <CGAL/Random.h>
-
-#include <array>
-#include <vector>
-
-namespace tc = Gudhi::tangential_complex;
-
-typedef CGAL::Epick_d<CGAL::Dynamic_dimension_tag> Kernel;
-typedef Kernel::FT FT;
-typedef Kernel::Point_d Point;
-typedef Kernel::Vector_d Vector;
-typedef tc::Tangential_complex<
-Kernel, CGAL::Dynamic_dimension_tag,
-CGAL::Parallel_tag> TC;
-
-int main(void) {
- const int INTRINSIC_DIM = 2;
- const int AMBIENT_DIM = 3;
- const int NUM_POINTS = 1000;
-
- Kernel k;
-
- // Generate points on a 2-sphere
- CGAL::Random_points_on_sphere_d<Point> generator(AMBIENT_DIM, 3.);
- std::vector<Point> points;
- points.reserve(NUM_POINTS);
- for (int i = 0; i < NUM_POINTS; ++i)
- points.push_back(*generator++);
-
- // Compute the TC
- TC tc(points, INTRINSIC_DIM, k);
- tc.compute_tangential_complex();
-
- // Export the TC into a Simplex_tree
- Gudhi::Simplex_tree<> stree;
- tc.create_complex(stree);
-
- // Display stats about inconsistencies
- tc.number_of_inconsistent_simplices(true); // verbose
-
- return 0;
-}
diff --git a/example/Tangential_complex/example_with_perturb.cpp b/example/Tangential_complex/example_with_perturb.cpp
deleted file mode 100644
index d0d877ea..00000000
--- a/example/Tangential_complex/example_with_perturb.cpp
+++ /dev/null
@@ -1,53 +0,0 @@
-#include <gudhi/Tangential_complex.h>
-#include <gudhi/sparsify_point_set.h>
-
-#include <CGAL/Epick_d.h>
-#include <CGAL/Random.h>
-
-#include <array>
-#include <vector>
-
-namespace subsampl = Gudhi::subsampling;
-namespace tc = Gudhi::tangential_complex;
-
-typedef CGAL::Epick_d<CGAL::Dimension_tag < 3 >> Kernel;
-typedef Kernel::FT FT;
-typedef Kernel::Point_d Point;
-typedef Kernel::Vector_d Vector;
-typedef tc::Tangential_complex<
-Kernel, CGAL::Dimension_tag<2>,
-CGAL::Parallel_tag> TC;
-
-int main(void) {
- const int INTRINSIC_DIM = 2;
- const int AMBIENT_DIM = 3;
- const int NUM_POINTS = 50;
-
- Kernel k;
-
- // Generate points on a 2-sphere
- CGAL::Random_points_on_sphere_d<Point> generator(AMBIENT_DIM, 3.);
- std::vector<Point> points;
- points.reserve(NUM_POINTS);
- for (int i = 0; i < NUM_POINTS; ++i)
- points.push_back(*generator++);
-
- // Sparsify the point set
- std::vector<Point> sparsified_points;
- subsampl::sparsify_point_set(k, points, 0.1 * 0.1,
- std::back_inserter(sparsified_points));
- sparsified_points.swap(points);
-
- // Compute the TC
- TC tc(points, INTRINSIC_DIM, k);
- tc.compute_tangential_complex();
-
- // Try to fix inconsistencies. Give it 10 seconds to succeed
- tc.fix_inconsistencies_using_perturbation(0.05, 10);
-
- // Export the TC into a Simplex_tree
- Gudhi::Simplex_tree<> stree;
- tc.create_complex(stree);
-
- return 0;
-}