summaryrefslogtreecommitdiff
path: root/src/Alpha_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Alpha_complex/test/CMakeLists.txt')
-rw-r--r--src/Alpha_complex/test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Alpha_complex/test/CMakeLists.txt b/src/Alpha_complex/test/CMakeLists.txt
index 79300790..87b05a3a 100644
--- a/src/Alpha_complex/test/CMakeLists.txt
+++ b/src/Alpha_complex/test/CMakeLists.txt
@@ -14,8 +14,11 @@ if(CGAL_FOUND)
message(STATUS "Eigen3 version: ${EIGEN3_VERSION}.")
include( ${EIGEN3_USE_FILE} )
include_directories (BEFORE "../../include")
+ if (CMAKE_BUILD_TYPE MATCHES Debug)
+ # For programs to be more verbose
+ add_definitions(-DDEBUG_TRACES)
+ endif()
- #add_definitions(-DDEBUG_TRACES)
add_executable ( AlphaComplexUT Alpha_complex_unit_test.cpp )
target_link_libraries(AlphaComplexUT ${Boost_SYSTEM_LIBRARY} ${CGAL_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
add_test(AlphaComplexUT ${CMAKE_CURRENT_BINARY_DIR}/AlphaComplexUT