summaryrefslogtreecommitdiff
path: root/src/Bitmap_cubical_complex/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Bitmap_cubical_complex/test/CMakeLists.txt')
-rw-r--r--src/Bitmap_cubical_complex/test/CMakeLists.txt22
1 files changed, 5 insertions, 17 deletions
diff --git a/src/Bitmap_cubical_complex/test/CMakeLists.txt b/src/Bitmap_cubical_complex/test/CMakeLists.txt
index daf0e14f..b2895f85 100644
--- a/src/Bitmap_cubical_complex/test/CMakeLists.txt
+++ b/src/Bitmap_cubical_complex/test/CMakeLists.txt
@@ -1,24 +1,12 @@
cmake_minimum_required(VERSION 2.6)
project(Bitmap_cubical_complex_tests)
-if (GCOVR_PATH)
- # for gcovr to make coverage reports - Corbera Jenkins plugin
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fprofile-arcs -ftest-coverage")
-endif()
-if (GPROF_PATH)
- # for gprof to make coverage reports - Jenkins
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pg")
-endif()
+include(GUDHI_test_coverage)
-add_executable ( BitmapCCUT Bitmap_test.cpp )
-target_link_libraries(BitmapCCUT ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
+add_executable ( Bitmap_cubical_complex_test_unit Bitmap_test.cpp )
+target_link_libraries(Bitmap_cubical_complex_test_unit ${Boost_SYSTEM_LIBRARY} ${Boost_UNIT_TEST_FRAMEWORK_LIBRARY})
if (TBB_FOUND)
- target_link_libraries(BitmapCCUT ${TBB_LIBRARIES})
+ target_link_libraries(Bitmap_cubical_complex_test_unit ${TBB_LIBRARIES})
endif()
-# Unitary tests
-add_test(NAME BitmapCCUT
- COMMAND ${CMAKE_CURRENT_BINARY_DIR}/BitmapCCUT
- # XML format for Jenkins xUnit plugin
- --log_format=XML --log_sink=${CMAKE_SOURCE_DIR}/BitmapCCUT.xml --log_level=test_suite --report_level=no)
-
+gudhi_add_coverage_test(Bitmap_cubical_complex_test_unit)