summaryrefslogtreecommitdiff
path: root/src/Bitmap_cubical_complex
diff options
context:
space:
mode:
Diffstat (limited to 'src/Bitmap_cubical_complex')
-rw-r--r--src/Bitmap_cubical_complex/example/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Bitmap_cubical_complex/example/CMakeLists.txt b/src/Bitmap_cubical_complex/example/CMakeLists.txt
index a0401619..66defc8f 100644
--- a/src/Bitmap_cubical_complex/example/CMakeLists.txt
+++ b/src/Bitmap_cubical_complex/example/CMakeLists.txt
@@ -6,6 +6,16 @@ if (TBB_FOUND)
target_link_libraries(Bitmap_cubical_complex ${TBB_LIBRARIES})
endif()
+add_executable ( cc_wit_hiraoka cc_wit_hiraoka.cpp )
+if (TBB_FOUND)
+ target_link_libraries(cc_wit_hiraoka ${TBB_LIBRARIES})
+endif()
+
+add_executable ( cc_wit_hiraoka_img cc_wit_hiraoka_img.cpp )
+if (TBB_FOUND)
+ target_link_libraries(cc_wit_hiraoka_img ${TBB_LIBRARIES})
+endif()
+
add_test(NAME Bitmap_cubical_complex_example_persistence_one_sphere COMMAND $<TARGET_FILE:Bitmap_cubical_complex>
"${CMAKE_SOURCE_DIR}/data/bitmap/CubicalOneSphere.txt")