summaryrefslogtreecommitdiff
path: root/src/Bottleneck_distance/utilities/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Bottleneck_distance/utilities/CMakeLists.txt')
-rw-r--r--src/Bottleneck_distance/utilities/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Bottleneck_distance/utilities/CMakeLists.txt b/src/Bottleneck_distance/utilities/CMakeLists.txt
new file mode 100644
index 00000000..86d74cf5
--- /dev/null
+++ b/src/Bottleneck_distance/utilities/CMakeLists.txt
@@ -0,0 +1,15 @@
+project(Bottleneck_distance_utilities)
+
+if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable (bottleneck_distance bottleneck_distance.cpp)
+ if (TBB_FOUND)
+ target_link_libraries(bottleneck_distance ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+
+ add_test(NAME Bottleneck_distance_utilities_Bottleneck_read_file
+ COMMAND $<TARGET_FILE:bottleneck_distance>
+ "${CMAKE_SOURCE_DIR}/data/persistence_diagram/first.pers" "${CMAKE_SOURCE_DIR}/data/persistence_diagram/second.pers")
+
+ install(TARGETS bottleneck_distance DESTINATION bin)
+
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)