summaryrefslogtreecommitdiff
path: root/src/Contraction
diff options
context:
space:
mode:
Diffstat (limited to 'src/Contraction')
-rw-r--r--src/Contraction/example/CMakeLists.txt2
-rw-r--r--src/Contraction/utilities/CMakeLists.txt6
-rw-r--r--src/Contraction/utilities/Garland_heckbert.cpp (renamed from src/Contraction/example/Garland_heckbert.cpp)6
-rw-r--r--src/Contraction/utilities/Garland_heckbert/Error_quadric.h (renamed from src/Contraction/example/Garland_heckbert/Error_quadric.h)0
4 files changed, 8 insertions, 6 deletions
diff --git a/src/Contraction/example/CMakeLists.txt b/src/Contraction/example/CMakeLists.txt
index 83594c0e..f02949e4 100644
--- a/src/Contraction/example/CMakeLists.txt
+++ b/src/Contraction/example/CMakeLists.txt
@@ -3,7 +3,6 @@ project(Contraction_examples)
add_executable(RipsContraction Rips_contraction.cpp)
-add_executable(GarlandHeckbert Garland_heckbert.cpp)
add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContraction>
"${CMAKE_SOURCE_DIR}/data/points/tore3D_1307.off" "0.2")
@@ -14,4 +13,3 @@ add_test(NAME Contraction_example_tore3D_0.2 COMMAND $<TARGET_FILE:RipsContracti
# "${CMAKE_SOURCE_DIR}/data/points/SO3_10000.off" "0.3")
install(TARGETS RipsContraction DESTINATION bin)
-install(TARGETS GarlandHeckbert DESTINATION bin)
diff --git a/src/Contraction/utilities/CMakeLists.txt b/src/Contraction/utilities/CMakeLists.txt
new file mode 100644
index 00000000..a18783ef
--- /dev/null
+++ b/src/Contraction/utilities/CMakeLists.txt
@@ -0,0 +1,6 @@
+cmake_minimum_required(VERSION 2.6)
+project(Contraction_utilities)
+
+add_executable(GarlandHeckbert Garland_heckbert.cpp)
+
+install(TARGETS GarlandHeckbert DESTINATION bin)
diff --git a/src/Contraction/example/Garland_heckbert.cpp b/src/Contraction/utilities/Garland_heckbert.cpp
index f0cde95e..8b5a6a6c 100644
--- a/src/Contraction/example/Garland_heckbert.cpp
+++ b/src/Contraction/utilities/Garland_heckbert.cpp
@@ -29,8 +29,8 @@
#include <gudhi/Edge_contraction.h>
#include <gudhi/Skeleton_blocker.h>
#include <gudhi/Off_reader.h>
-#include <gudhi/Clock.h>
+#include <boost/timer/timer.hpp>
#include <iostream>
#include "Garland_heckbert/Error_quadric.h"
@@ -165,7 +165,7 @@ int main(int argc, char *argv[]) {
int num_contractions = atoi(argv[3]);
- Gudhi::Clock contraction_chrono("Time to simplify and enumerate simplices");
+ boost::timer::auto_cpu_timer t;
// constructs the contractor object with Garland Heckbert policies.
Complex_contractor contractor(complex,
@@ -182,8 +182,6 @@ int main(int argc, char *argv[]) {
complex.num_edges() << " edges and " <<
complex.num_triangles() << " triangles." << std::endl;
- std::cout << contraction_chrono;
-
// write simplified complex
Gudhi::skeleton_blocker::Skeleton_blocker_off_writer<Complex> off_writer(argv[2], complex);
diff --git a/src/Contraction/example/Garland_heckbert/Error_quadric.h b/src/Contraction/utilities/Garland_heckbert/Error_quadric.h
index e7dafaa0..e7dafaa0 100644
--- a/src/Contraction/example/Garland_heckbert/Error_quadric.h
+++ b/src/Contraction/utilities/Garland_heckbert/Error_quadric.h