summaryrefslogtreecommitdiff
path: root/src/Persistent_cohomology/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Persistent_cohomology/example/CMakeLists.txt')
-rw-r--r--src/Persistent_cohomology/example/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/Persistent_cohomology/example/CMakeLists.txt b/src/Persistent_cohomology/example/CMakeLists.txt
index f6c866dc..5f711961 100644
--- a/src/Persistent_cohomology/example/CMakeLists.txt
+++ b/src/Persistent_cohomology/example/CMakeLists.txt
@@ -123,6 +123,13 @@ if(CGAL_FOUND)
install(TARGETS weighted_periodic_alpha_complex_3d_persistence DESTINATION bin)
+ add_executable(test_cgal test_cgal.cpp)
+ target_link_libraries(test_cgal ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(test_cgal ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+
+
# On CGAL 4.11, the weighted alpha shape 3 interface was changed - the new interface
add_executable(weighted_alpha_complex_3d_persistence weighted_alpha_complex_3d_persistence.cpp)
else(NOT CGAL_VERSION VERSION_LESS 4.11.0)