summaryrefslogtreecommitdiff
path: root/src/Skeleton_blocker/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Skeleton_blocker/example/CMakeLists.txt')
-rw-r--r--src/Skeleton_blocker/example/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/Skeleton_blocker/example/CMakeLists.txt b/src/Skeleton_blocker/example/CMakeLists.txt
new file mode 100644
index 00000000..0e5d2f11
--- /dev/null
+++ b/src/Skeleton_blocker/example/CMakeLists.txt
@@ -0,0 +1,13 @@
+project(Skeleton_blocker_examples)
+
+add_executable(Skeleton_blocker_example_from_simplices Skeleton_blocker_from_simplices.cpp)
+add_executable(Skeleton_blocker_example_iteration Skeleton_blocker_iteration.cpp)
+add_executable(Skeleton_blocker_example_link Skeleton_blocker_link.cpp)
+
+add_test(NAME Skeleton_blocker_example_from_simplices COMMAND $<TARGET_FILE:Skeleton_blocker_example_from_simplices>)
+add_test(NAME Skeleton_blocker_example_iteration COMMAND $<TARGET_FILE:Skeleton_blocker_example_iteration>)
+add_test(NAME Skeleton_blocker_example_link COMMAND $<TARGET_FILE:Skeleton_blocker_example_link>)
+
+install(TARGETS Skeleton_blocker_example_from_simplices DESTINATION bin)
+install(TARGETS Skeleton_blocker_example_iteration DESTINATION bin)
+install(TARGETS Skeleton_blocker_example_link DESTINATION bin)