summaryrefslogtreecommitdiff
path: root/src/Spatial_searching/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/Spatial_searching/example/CMakeLists.txt')
-rw-r--r--src/Spatial_searching/example/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/Spatial_searching/example/CMakeLists.txt b/src/Spatial_searching/example/CMakeLists.txt
new file mode 100644
index 00000000..eeb3e85f
--- /dev/null
+++ b/src/Spatial_searching/example/CMakeLists.txt
@@ -0,0 +1,9 @@
+project(Spatial_searching_examples)
+
+if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable( Spatial_searching_example_spatial_searching example_spatial_searching.cpp )
+ target_link_libraries(Spatial_searching_example_spatial_searching ${CGAL_LIBRARY})
+ add_test(NAME Spatial_searching_example_spatial_searching
+ COMMAND $<TARGET_FILE:Spatial_searching_example_spatial_searching>)
+ install(TARGETS Spatial_searching_example_spatial_searching DESTINATION bin)
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)