summaryrefslogtreecommitdiff
path: root/src/Tangential_complex/example
diff options
context:
space:
mode:
Diffstat (limited to 'src/Tangential_complex/example')
-rw-r--r--src/Tangential_complex/example/CMakeLists.txt20
-rw-r--r--src/Tangential_complex/example/example_basic.cpp49
-rw-r--r--src/Tangential_complex/example/example_with_perturb.cpp53
3 files changed, 122 insertions, 0 deletions
diff --git a/src/Tangential_complex/example/CMakeLists.txt b/src/Tangential_complex/example/CMakeLists.txt
new file mode 100644
index 00000000..cb1486a4
--- /dev/null
+++ b/src/Tangential_complex/example/CMakeLists.txt
@@ -0,0 +1,20 @@
+project(Tangential_complex_examples)
+
+if(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
+ add_executable( Tangential_complex_example_basic example_basic.cpp )
+ target_link_libraries(Tangential_complex_example_basic ${CGAL_LIBRARY})
+ add_executable( Tangential_complex_example_with_perturb example_with_perturb.cpp )
+ target_link_libraries(Tangential_complex_example_with_perturb ${CGAL_LIBRARY})
+ if (TBB_FOUND)
+ target_link_libraries(Tangential_complex_example_basic ${TBB_LIBRARIES})
+ target_link_libraries(Tangential_complex_example_with_perturb ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+
+ add_test(NAME Tangential_complex_example_basic
+ COMMAND $<TARGET_FILE:Tangential_complex_example_basic>)
+ add_test(NAME Tangential_complex_example_with_perturb
+ COMMAND $<TARGET_FILE:Tangential_complex_example_with_perturb>)
+
+ install(TARGETS Tangential_complex_example_basic DESTINATION bin)
+ install(TARGETS Tangential_complex_example_with_perturb DESTINATION bin)
+endif(NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.11.0)
diff --git a/src/Tangential_complex/example/example_basic.cpp b/src/Tangential_complex/example/example_basic.cpp
new file mode 100644
index 00000000..ab35edf0
--- /dev/null
+++ b/src/Tangential_complex/example/example_basic.cpp
@@ -0,0 +1,49 @@
+#include <gudhi/Tangential_complex.h>
+#include <gudhi/sparsify_point_set.h>
+//#include <gudhi/Fake_simplex_tree.h>
+
+
+#include <CGAL/Epick_d.h>
+#include <CGAL/Random.h>
+
+#include <array>
+#include <vector>
+
+namespace tc = Gudhi::tangential_complex;
+
+typedef CGAL::Epick_d<CGAL::Dynamic_dimension_tag> Kernel;
+typedef Kernel::FT FT;
+typedef Kernel::Point_d Point;
+typedef Kernel::Vector_d Vector;
+typedef tc::Tangential_complex<
+Kernel, CGAL::Dynamic_dimension_tag,
+CGAL::Parallel_tag> TC;
+
+int main(void) {
+ const int INTRINSIC_DIM = 2;
+ const int AMBIENT_DIM = 3;
+ const int NUM_POINTS = 100;
+
+ Kernel k;
+
+ // Generate points on a 2-sphere
+ CGAL::Random_points_on_sphere_d<Point> generator(AMBIENT_DIM, 3.);
+ std::vector<Point> points;
+ points.reserve(NUM_POINTS);
+ for (int i = 0; i < NUM_POINTS; ++i)
+ points.push_back(*generator++);
+
+ // Compute the TC
+ TC tc(points, INTRINSIC_DIM, k);
+ tc.compute_tangential_complex();
+
+ // Export the TC into a Simplex_tree
+ Gudhi::Simplex_tree<> stree;
+ //Gudhi::Fake_simplex_tree stree;
+ tc.create_complex(stree);
+
+ // Display stats about inconsistencies
+ tc.number_of_inconsistent_simplices(true); // verbose
+
+ return 0;
+}
diff --git a/src/Tangential_complex/example/example_with_perturb.cpp b/src/Tangential_complex/example/example_with_perturb.cpp
new file mode 100644
index 00000000..d0d877ea
--- /dev/null
+++ b/src/Tangential_complex/example/example_with_perturb.cpp
@@ -0,0 +1,53 @@
+#include <gudhi/Tangential_complex.h>
+#include <gudhi/sparsify_point_set.h>
+
+#include <CGAL/Epick_d.h>
+#include <CGAL/Random.h>
+
+#include <array>
+#include <vector>
+
+namespace subsampl = Gudhi::subsampling;
+namespace tc = Gudhi::tangential_complex;
+
+typedef CGAL::Epick_d<CGAL::Dimension_tag < 3 >> Kernel;
+typedef Kernel::FT FT;
+typedef Kernel::Point_d Point;
+typedef Kernel::Vector_d Vector;
+typedef tc::Tangential_complex<
+Kernel, CGAL::Dimension_tag<2>,
+CGAL::Parallel_tag> TC;
+
+int main(void) {
+ const int INTRINSIC_DIM = 2;
+ const int AMBIENT_DIM = 3;
+ const int NUM_POINTS = 50;
+
+ Kernel k;
+
+ // Generate points on a 2-sphere
+ CGAL::Random_points_on_sphere_d<Point> generator(AMBIENT_DIM, 3.);
+ std::vector<Point> points;
+ points.reserve(NUM_POINTS);
+ for (int i = 0; i < NUM_POINTS; ++i)
+ points.push_back(*generator++);
+
+ // Sparsify the point set
+ std::vector<Point> sparsified_points;
+ subsampl::sparsify_point_set(k, points, 0.1 * 0.1,
+ std::back_inserter(sparsified_points));
+ sparsified_points.swap(points);
+
+ // Compute the TC
+ TC tc(points, INTRINSIC_DIM, k);
+ tc.compute_tangential_complex();
+
+ // Try to fix inconsistencies. Give it 10 seconds to succeed
+ tc.fix_inconsistencies_using_perturbation(0.05, 10);
+
+ // Export the TC into a Simplex_tree
+ Gudhi::Simplex_tree<> stree;
+ tc.create_complex(stree);
+
+ return 0;
+}