summaryrefslogtreecommitdiff
path: root/src/Toplex_map/benchmark
diff options
context:
space:
mode:
Diffstat (limited to 'src/Toplex_map/benchmark')
-rw-r--r--src/Toplex_map/benchmark/CMakeLists.txt2
-rw-r--r--src/Toplex_map/benchmark/benchmark_tm.cpp (renamed from src/Toplex_map/benchmark/chrono.cpp)4
2 files changed, 3 insertions, 3 deletions
diff --git a/src/Toplex_map/benchmark/CMakeLists.txt b/src/Toplex_map/benchmark/CMakeLists.txt
index c2f216bc..2d58a156 100644
--- a/src/Toplex_map/benchmark/CMakeLists.txt
+++ b/src/Toplex_map/benchmark/CMakeLists.txt
@@ -1,3 +1,3 @@
project(Toplex_map_benchmark)
-add_executable(toplex_map_chrono chrono.cpp)
+add_executable(Toplex_map_benchmark benchmark_tm.cpp)
diff --git a/src/Toplex_map/benchmark/chrono.cpp b/src/Toplex_map/benchmark/benchmark_tm.cpp
index e6172c61..5f13288c 100644
--- a/src/Toplex_map/benchmark/chrono.cpp
+++ b/src/Toplex_map/benchmark/benchmark_tm.cpp
@@ -4,7 +4,7 @@
#include <gudhi/Simplex_tree.h>
#include <gudhi/Toplex_map.h>
-#include <gudhi/Lazy_Toplex_map.h>
+#include <gudhi/Lazy_toplex_map.h>
using namespace Gudhi;
@@ -119,7 +119,7 @@ int main(){
std::cout << "T Map \t \t";
chrono<Toplex_map>(n,d);
std::cout << "Lazy \t \t";
- chrono<Lazy_Toplex_map>(n,d);
+ chrono<Lazy_toplex_map>(n,d);
if(d<=15){
std::cout << "ST \t \t";
chrono<ST_wrapper>(n,d);