summaryrefslogtreecommitdiff
path: root/src/cython/setup.py.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/cython/setup.py.in')
-rw-r--r--src/cython/setup.py.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/cython/setup.py.in b/src/cython/setup.py.in
index 4037aab6..c66905ac 100644
--- a/src/cython/setup.py.in
+++ b/src/cython/setup.py.in
@@ -1,5 +1,6 @@
from distutils.core import setup, Extension
from Cython.Build import cythonize
+from numpy import get_include as numpy_get_include
"""This file is part of the Gudhi Library. The Gudhi library
(Geometric Understanding in Higher Dimensions) is a generic C++
@@ -7,7 +8,7 @@ from Cython.Build import cythonize
Author(s): Vincent Rouvreau
- Copyright (C) 2016 Inria
+ Copyright (C) 2019 Inria
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
@@ -35,7 +36,7 @@ gudhi = Extension(
extra_link_args=[@GUDHI_CYTHON_EXTRA_LINK_ARGS@],
libraries=[@GUDHI_CYTHON_LIBRARIES@],
library_dirs=[@GUDHI_CYTHON_LIBRARY_DIRS@],
- include_dirs = [@GUDHI_CYTHON_INCLUDE_DIRS@],
+ include_dirs = [numpy_get_include(), @GUDHI_CYTHON_INCLUDE_DIRS@],
runtime_library_dirs=[@GUDHI_CYTHON_RUNTIME_LIBRARY_DIRS@],
)
@@ -46,5 +47,6 @@ setup(
version='@GUDHI_VERSION@',
url='http://gudhi.gforge.inria.fr/',
ext_modules = cythonize(gudhi),
- install_requires = ["cython",],
+ install_requires = ['cython','numpy >= 1.9',],
+ setup_requires = ['numpy >= 1.9',],
)