summaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
Diffstat (limited to 'src')
-rw-r--r--src/python/doc/installation.rst21
1 files changed, 13 insertions, 8 deletions
diff --git a/src/python/doc/installation.rst b/src/python/doc/installation.rst
index c3ddc017..14000ecf 100644
--- a/src/python/doc/installation.rst
+++ b/src/python/doc/installation.rst
@@ -83,32 +83,37 @@ Or install it definitely in your Python packages folder:
.. code-block:: bash
- python setup.py install --prefix /home/gudhi # Install in /home/gudhi directory
+ python setup.py install --prefix /home/gudhi # Install in /home/gudhi directory
Test suites
===========
-To test your build, `py.test <http://doc.pytest.org>`_ is optional. Run the
-following command in a terminal:
+To test your build, `py.test <http://doc.pytest.org>`_ is required. Run the
+following `Ctest <https://cmake.org/cmake/help/latest/manual/ctest.1.html>`_
+(CMake test driver program) command in a terminal:
.. code-block:: bash
cd /path-to-gudhi/build/python
# For windows, you have to set PYTHONPATH environment variable
export PYTHONPATH='$PYTHONPATH:/path-to-gudhi/build/python'
- make test
+ ctest
+<<<<<<< HEAD
+.. note::
+
+ One can use :code:`ctest` specific options in the python directory:
+=======
`make test` is using
`Ctest <https://cmake.org/cmake/help/latest/manual/ctest.1.html>`_ (CMake test
driver program). If some of the tests are failing, please send us the result of
the following command:
+>>>>>>> a1b6e5a034bc698b02d3c93e1707cab5622eaea6
.. code-block:: bash
- cd /path-to-gudhi/build/python
- # For windows, you have to set PYTHONPATH environment variable
- export PYTHONPATH='$PYTHONPATH:/path-to-gudhi/build/python'
- ctest --output-on-failure
+ # Launch tests in parallel on 8 cores and set failing tests in verbose mode
+ ctest -j 8 --output-on-failure
Debugging issues
================