summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt')
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt b/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt
new file mode 100644
index 00000000..386e9fa5
--- /dev/null
+++ b/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 2.6)
+project(Persistence_representations_heat_maps_utilities)
+
+add_persistence_representation_creation_utility(create_pssk "10" "-1" "-1" "4" "-1")
+add_persistence_representation_creation_utility(create_p_h_m_weighted_by_arctan_of_their_persistence "10" "-1" "-1" "4" "-1")
+add_persistence_representation_creation_utility(create_p_h_m_weighted_by_distance_from_diagonal "10" "-1" "-1" "4" "-1")
+add_persistence_representation_creation_utility(create_p_h_m_weighted_by_squared_diag_distance "10" "-1" "-1" "4" "-1")
+# Need to set grid min and max for further average, distance and scalar_product
+add_persistence_representation_creation_utility(create_persistence_heat_maps "10" "0" "35" "10" "-1")
+
+add_persistence_representation_plot_utility(plot_persistence_heat_map ".mps")
+
+add_persistence_representation_function_utility(average_persistence_heat_maps ".mps")
+add_persistence_representation_function_utility(compute_distance_of_persistence_heat_maps ".mps" "1")
+add_persistence_representation_function_utility(compute_scalar_product_of_persistence_heat_maps ".mps")