summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/persistence_heat_maps
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/Persistence_representations/persistence_heat_maps')
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt14
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/average_persistence_heat_maps.cpp63
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/compute_distance_of_persistence_heat_maps.cpp94
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps.cpp85
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_arctan_of_their_persistence.cpp81
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_distance_from_diagonal.cpp81
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_squared_diag_distance.cpp83
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/create_persistence_heat_maps.cpp78
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/create_pssk.cpp79
-rw-r--r--utilities/Persistence_representations/persistence_heat_maps/plot_persistence_heat_map.cpp42
10 files changed, 0 insertions, 700 deletions
diff --git a/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt b/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt
deleted file mode 100644
index 89ef232f..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-project(Persistence_representations_heat_maps_utilities)
-
-add_persistence_representation_creation_utility(create_pssk "10" "-1" "-1" "4" "-1")
-add_persistence_representation_creation_utility(create_p_h_m_weighted_by_arctan_of_their_persistence "10" "-1" "-1" "4" "-1")
-add_persistence_representation_creation_utility(create_p_h_m_weighted_by_distance_from_diagonal "10" "-1" "-1" "4" "-1")
-add_persistence_representation_creation_utility(create_p_h_m_weighted_by_squared_diag_distance "10" "-1" "-1" "4" "-1")
-# Need to set grid min and max for further average, distance and scalar_product
-add_persistence_representation_creation_utility(create_persistence_heat_maps "10" "0" "35" "10" "-1")
-
-add_persistence_representation_plot_utility(plot_persistence_heat_map ".mps")
-
-add_persistence_representation_function_utility(average_persistence_heat_maps ".mps")
-add_persistence_representation_function_utility(compute_distance_of_persistence_heat_maps ".mps" "1")
-add_persistence_representation_function_utility(compute_scalar_product_of_persistence_heat_maps ".mps")
diff --git a/utilities/Persistence_representations/persistence_heat_maps/average_persistence_heat_maps.cpp b/utilities/Persistence_representations/persistence_heat_maps/average_persistence_heat_maps.cpp
deleted file mode 100644
index 2cbd812b..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/average_persistence_heat_maps.cpp
+++ /dev/null
@@ -1,63 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <vector>
-
-using constant_scaling_function = Gudhi::Persistence_representations::constant_scaling_function;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<constant_scaling_function>;
-
-int main(int argc, char** argv) {
- std::cout << "This program computes average of persistence heat maps stored in files (the files needs to be "
- << "created beforehand).\n"
- << "The parameters of this programs are names of files with persistence heat maps.\n";
-
- if (argc < 3) {
- std::cout << "Wrong number of parameters, the program will now terminate \n";
- return 1;
- }
-
- std::vector<const char*> filenames;
- for (int i = 1; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<Persistence_heat_maps*> maps;
- for (size_t i = 0; i != filenames.size(); ++i) {
- Persistence_heat_maps* l = new Persistence_heat_maps;
- l->load_from_file(filenames[i]);
- maps.push_back(l);
- }
-
- Persistence_heat_maps av;
- av.compute_average(maps);
- av.print_to_file("average.mps");
-
- for (size_t i = 0; i != filenames.size(); ++i) {
- delete maps[i];
- }
-
- std::cout << "Average can be found in 'average.mps' file\n";
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/compute_distance_of_persistence_heat_maps.cpp b/utilities/Persistence_representations/persistence_heat_maps/compute_distance_of_persistence_heat_maps.cpp
deleted file mode 100644
index 14d0db8f..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/compute_distance_of_persistence_heat_maps.cpp
+++ /dev/null
@@ -1,94 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using constant_scaling_function = Gudhi::Persistence_representations::constant_scaling_function;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<constant_scaling_function>;
-
-int main(int argc, char** argv) {
- std::cout << "This program computes distance of persistence heat maps stored in files (the files needs to be "
- << "created beforehand).\n"
- << "The first parameter of a program is an integer p. The program compute L^p distance of the two heat "
- << "maps. For L^infty distance choose p = -1. \n"
- << "The remaining parameters of this program are names of files with persistence heat maps.\n";
-
- if (argc < 3) {
- std::cout << "Wrong number of parameters, the program will now terminate \n";
- return 1;
- }
-
- int pp = atoi(argv[1]);
- double p = std::numeric_limits<double>::max();
- if (pp != -1) {
- p = pp;
- }
-
- std::vector<const char*> filenames;
- for (int i = 2; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
- std::vector<Persistence_heat_maps> maps;
- maps.reserve(filenames.size());
- for (size_t file_no = 0; file_no != filenames.size(); ++file_no) {
- Persistence_heat_maps l;
- l.load_from_file(filenames[file_no]);
- maps.push_back(l);
- }
-
- // and now we will compute the scalar product of landscapes.
-
- // first we prepare an array:
- std::vector<std::vector<double> > distance(filenames.size());
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::vector<double> v(filenames.size(), 0);
- distance[i] = v;
- }
-
- // and now we can compute the distances:
- for (size_t i = 0; i != filenames.size(); ++i) {
- for (size_t j = i; j != filenames.size(); ++j) {
- distance[i][j] = distance[j][i] = maps[i].distance(maps[j], p);
- }
- }
-
- // and now output the result to the screen and a file:
- std::ofstream out;
- out.open("distance.mps");
- for (size_t i = 0; i != distance.size(); ++i) {
- for (size_t j = 0; j != distance.size(); ++j) {
- std::cout << distance[i][j] << " ";
- out << distance[i][j] << " ";
- }
- std::cout << std::endl;
- out << std::endl;
- }
- out.close();
-
- std::cout << "Distance can be found in 'distance.mps' file\n";
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps.cpp b/utilities/Persistence_representations/persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps.cpp
deleted file mode 100644
index 12fceedc..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/compute_scalar_product_of_persistence_heat_maps.cpp
+++ /dev/null
@@ -1,85 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-#include <vector>
-
-using constant_scaling_function = Gudhi::Persistence_representations::constant_scaling_function;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<constant_scaling_function>;
-
-int main(int argc, char** argv) {
- std::cout << "This program computes scalar product of persistence heat maps stored in a file (the file needs to be "
- << "created beforehand). \n"
- << "The parameters of this programs are names of files with persistence heat maps.\n";
-
- if (argc < 3) {
- std::cout << "Wrong number of parameters, the program will now terminate \n";
- return 1;
- }
-
- std::vector<const char*> filenames;
- for (int i = 1; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
- std::vector<Persistence_heat_maps> maps;
- maps.reserve(filenames.size());
- for (size_t file_no = 0; file_no != filenames.size(); ++file_no) {
- Persistence_heat_maps l;
- l.load_from_file(filenames[file_no]);
- maps.push_back(l);
- }
-
- // and now we will compute the scalar product of landscapes.
-
- // first we prepare an array:
- std::vector<std::vector<double> > scalar_product(filenames.size());
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::vector<double> v(filenames.size(), 0);
- scalar_product[i] = v;
- }
-
- // and now we can compute the scalar product:
- for (size_t i = 0; i != maps.size(); ++i) {
- for (size_t j = i; j != maps.size(); ++j) {
- scalar_product[i][j] = scalar_product[j][i] = maps[i].compute_scalar_product(maps[j]);
- }
- }
-
- // and now output the result to the screen and a file:
- std::ofstream out;
- out.open("scalar_product.mps");
- for (size_t i = 0; i != scalar_product.size(); ++i) {
- for (size_t j = 0; j != scalar_product.size(); ++j) {
- std::cout << scalar_product[i][j] << " ";
- out << scalar_product[i][j] << " ";
- }
- std::cout << std::endl;
- out << std::endl;
- }
- out.close();
-
- std::cout << "Distance can be found in 'scalar_product.mps' file\n";
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_arctan_of_their_persistence.cpp b/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_arctan_of_their_persistence.cpp
deleted file mode 100644
index 21c553b9..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_arctan_of_their_persistence.cpp
+++ /dev/null
@@ -1,81 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
-* (Geometric Understanding in Higher Dimensions) is a generic C++
-* library for computational topology.
-*
-* Author(s): Pawel Dlotko
-*
-* Copyright (C) 2016 Inria
-*
-* This program is free software: you can redistribute it and/or modify
-* it under the terms of the GNU General Public License as published by
-* the Free Software Foundation, either version 3 of the License, or
-* (at your option) any later version.
-*
-* This program is distributed in the hope that it will be useful,
-* but WITHOUT ANY WARRANTY; without even the implied warranty of
-* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-* GNU General Public License for more details.
-*
-* You should have received a copy of the GNU General Public License
-* along with this program. If not, see <http://www.gnu.org/licenses/>.
-*/
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using arc_tan_of_persistence_of_point = Gudhi::Persistence_representations::arc_tan_of_persistence_of_point;
-using Persistence_heat_maps =
- Gudhi::Persistence_representations::Persistence_heat_maps<arc_tan_of_persistence_of_point>;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates persistence heat map files (*.mps) of persistence diagrams files (*.pers) "
- << "provided as an input.The Gaussian kernels are weighted by the arc tangential of their persistence.\n"
- << "The first parameter of a program is an integer, a size of a grid.\n"
- << "The second and third parameters are min and max of the grid. If you want those numbers to be computed "
- << "based on the data, set them both to -1 \n"
- << "The fourth parameter is an integer, the standard deviation of a Gaussian kernel expressed in a number "
- << "of pixels.\n"
- << "The fifth parameter of this program is a dimension of persistence that will be used in creation of "
- << "the persistence heat maps."
- << "If your input files contains persistence pairs of various dimension, as a fifth parameter of the "
- << "procedure please provide the dimension of persistence you want to use."
- << "If in your files there are only birth-death pairs of the same dimension, set the fifth parameter to "
- << "-1.\n"
- << "The remaining parameters are the names of files with persistence diagrams. \n";
-
- if (argc < 7) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
-
- size_t size_of_grid = (size_t)atoi(argv[1]);
- double min_ = atof(argv[2]);
- double max_ = atof(argv[3]);
- size_t stdiv = atof(argv[4]);
-
- unsigned dimension = std::numeric_limits<unsigned>::max();
- int dim = atoi(argv[5]);
- if (dim >= 0) {
- dimension = (unsigned)dim;
- }
-
- std::vector<const char*> filenames;
- for (int i = 6; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<std::vector<double> > filter = Gudhi::Persistence_representations::create_Gaussian_filter(stdiv, 1);
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::cout << "Creating a heat map based on a file : " << filenames[i] << std::endl;
- Persistence_heat_maps l(filenames[i], filter, false, size_of_grid, min_, max_, dimension);
-
- std::stringstream ss;
- ss << filenames[i] << ".mps";
- l.print_to_file(ss.str().c_str());
- }
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_distance_from_diagonal.cpp b/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_distance_from_diagonal.cpp
deleted file mode 100644
index 99b0bd17..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_distance_from_diagonal.cpp
+++ /dev/null
@@ -1,81 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using distance_from_diagonal_scaling = Gudhi::Persistence_representations::distance_from_diagonal_scaling;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<distance_from_diagonal_scaling>;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates persistence heat map files (*.mps) of persistence diagrams files (*.pers) "
- << "provided as an input.The Gaussian kernels are weighted by the distance of a center from the "
- << "diagonal.\n"
- << "The first parameter of a program is an integer, a size of a grid.\n"
- << "The second and third parameters are min and max of the grid. If you want those numbers to be computed "
- << "based on the data, set them both to -1 \n"
- << "The fourth parameter is an integer, the standard deviation of a Gaussian kernel expressed in a number "
- << "of pixels.\n"
- << "The fifth parameter of this program is a dimension of persistence that will be used in creation of "
- << "the persistence heat maps."
- << "If your input files contains persistence pairs of various dimension, as a fifth parameter of the "
- << "procedure please provide the dimension of persistence you want to use."
- << "If in your files there are only birth-death pairs of the same dimension, set the fifth parameter to "
- << "-1.\n"
- << "The remaining parameters are the names of files with persistence diagrams. \n";
-
- if (argc < 7) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
-
- size_t size_of_grid = (size_t)atoi(argv[1]);
- double min_ = atof(argv[2]);
- double max_ = atof(argv[3]);
- size_t stdiv = atof(argv[4]);
-
- unsigned dimension = std::numeric_limits<unsigned>::max();
- int dim = atoi(argv[5]);
- if (dim >= 0) {
- dimension = (unsigned)dim;
- }
-
- std::vector<const char*> filenames;
- for (int i = 6; i != argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<std::vector<double> > filter = Gudhi::Persistence_representations::create_Gaussian_filter(stdiv, 1);
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::cout << "Creating a heat map based on a file : " << filenames[i] << std::endl;
- Persistence_heat_maps l(filenames[i], filter, false, size_of_grid, min_, max_, dimension);
-
- std::stringstream ss;
- ss << filenames[i] << ".mps";
- l.print_to_file(ss.str().c_str());
- }
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_squared_diag_distance.cpp b/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_squared_diag_distance.cpp
deleted file mode 100644
index a4b6e458..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/create_p_h_m_weighted_by_squared_diag_distance.cpp
+++ /dev/null
@@ -1,83 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using squared_distance_from_diagonal_scaling =
- Gudhi::Persistence_representations::squared_distance_from_diagonal_scaling;
-using Persistence_heat_maps =
- Gudhi::Persistence_representations::Persistence_heat_maps<squared_distance_from_diagonal_scaling>;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates persistence heat map files (*.mps) of persistence diagrams files (*.pers) "
- << "provided as an input.The Gaussian kernels are weighted by the square of distance of a center from the "
- << "diagonal.\n"
- << "The first parameter of a program is an integer, a size of a grid.\n"
- << "The second and third parameters are min and max of the grid. If you want those numbers to be computed "
- << "based on the data, set them both to -1 \n"
- << "The fourth parameter is an integer, the standard deviation of a Gaussian kernel expressed in a number "
- << "of pixels.\n"
- << "The fifth parameter of this program is a dimension of persistence that will be used in creation of "
- << "the persistence heat maps."
- << "If your input files contains persistence pairs of various dimension, as a fifth parameter of the "
- << "procedure please provide the dimension of persistence you want to use."
- << "If in your files there are only birth-death pairs of the same dimension, set the fifth parameter to "
- << "-1.\n"
- << "The remaining parameters are the names of files with persistence diagrams. \n";
-
- if (argc < 7) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
-
- size_t size_of_grid = (size_t)atoi(argv[1]);
- double min_ = atof(argv[2]);
- double max_ = atof(argv[3]);
- size_t stdiv = atof(argv[4]);
-
- unsigned dimension = std::numeric_limits<unsigned>::max();
- int dim = atoi(argv[5]);
- if (dim >= 0) {
- dimension = (unsigned)dim;
- }
-
- std::vector<const char*> filenames;
- for (int i = 6; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<std::vector<double> > filter = Gudhi::Persistence_representations::create_Gaussian_filter(stdiv, 1);
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::cout << "Creating a heat map based on a file : " << filenames[i] << std::endl;
- Persistence_heat_maps l(filenames[i], filter, false, size_of_grid, min_, max_, dimension);
-
- std::stringstream ss;
- ss << filenames[i] << ".mps";
- l.print_to_file(ss.str().c_str());
- }
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/create_persistence_heat_maps.cpp b/utilities/Persistence_representations/persistence_heat_maps/create_persistence_heat_maps.cpp
deleted file mode 100644
index 5960a89f..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/create_persistence_heat_maps.cpp
+++ /dev/null
@@ -1,78 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using constant_scaling_function = Gudhi::Persistence_representations::constant_scaling_function;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<constant_scaling_function>;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates persistence heat map files (*.mps) of persistence diagrams files (*.pers) "
- << "provided as an input.\n"
- << "The first parameter of a program is an integer, a size of a grid.\n"
- << "The second and third parameters are min and max of the grid. If you want those numbers to be computed "
- << "based on the data, set them both to -1 \n"
- << "The fourth parameter is an integer, the standard deviation of a Gaussian kernel expressed in a number "
- << "of pixels.\n"
- << "The fifth parameter of this program is a dimension of persistence that will be used in creation of "
- << "the persistence heat maps."
- << "If your input files contains persistence pairs of various dimension, as a fifth parameter of the "
- << "procedure please provide the dimension of persistence you want to use."
- << "If in your files there are only birth-death pairs of the same dimension, set the fifth parameter to "
- << "-1.\n"
- << "The remaining parameters are the names of files with persistence diagrams. \n";
-
- if (argc < 7) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
- size_t size_of_grid = (size_t)atoi(argv[1]);
- double min_ = atof(argv[2]);
- double max_ = atof(argv[3]);
- size_t stdiv = atof(argv[4]);
-
- unsigned dimension = std::numeric_limits<unsigned>::max();
- int dim = atoi(argv[5]);
- if (dim >= 0) {
- dimension = (unsigned)dim;
- }
- std::vector<const char*> filenames;
- for (int i = 6; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<std::vector<double> > filter = Gudhi::Persistence_representations::create_Gaussian_filter(stdiv, 1);
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::cout << "Creating a heat map based on file : " << filenames[i] << std::endl;
- Persistence_heat_maps l(filenames[i], filter, false, size_of_grid, min_, max_, dimension);
-
- std::stringstream ss;
- ss << filenames[i] << ".mps";
- l.print_to_file(ss.str().c_str());
- }
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/create_pssk.cpp b/utilities/Persistence_representations/persistence_heat_maps/create_pssk.cpp
deleted file mode 100644
index 04f33915..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/create_pssk.cpp
+++ /dev/null
@@ -1,79 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/PSSK.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using PSSK = Gudhi::Persistence_representations::PSSK;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates PSSK files (*.pssk) of persistence diagrams files (*.pers) "
- << "provided as an input.\n"
- << "The first parameter of a program is an integer, a size of a grid.\n"
- << "The second and third parameters are min and max of the grid. If you want those numbers to be computed "
- << "based on the data, set them both to -1 \n"
- << "The fourth parameter is an integer, the standard deviation of a Gaussian kernel expressed in a number "
- << "of pixels.\n"
- << "The fifth parameter of this program is a dimension of persistence that will be used in creation of "
- << "the PSSK."
- << "If your input files contains persistence pairs of various dimension, as a fifth parameter of the "
- << "procedure please provide the dimension of persistence you want to use."
- << "If in your files there are only birth-death pairs of the same dimension, set the first parameter to "
- << "-1.\n"
- << "The remaining parameters are the names of files with persistence diagrams. \n";
-
- if (argc < 7) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
-
- size_t size_of_grid = (size_t)atoi(argv[1]);
- double min_ = atof(argv[2]);
- double max_ = atof(argv[3]);
- size_t stdiv = atof(argv[4]);
-
- unsigned dimension = std::numeric_limits<unsigned>::max();
- int dim = atoi(argv[5]);
- if (dim >= 0) {
- dimension = (unsigned)dim;
- }
-
- std::vector<const char*> filenames;
- for (int i = 6; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<std::vector<double> > filter = Gudhi::Persistence_representations::create_Gaussian_filter(stdiv, 1);
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::cout << "Creating a PSSK based on a file : " << filenames[i] << std::endl;
- PSSK l(filenames[i], filter, size_of_grid, min_, max_, dimension);
-
- std::stringstream ss;
- ss << filenames[i] << ".pssk";
- l.print_to_file(ss.str().c_str());
- }
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_heat_maps/plot_persistence_heat_map.cpp b/utilities/Persistence_representations/persistence_heat_maps/plot_persistence_heat_map.cpp
deleted file mode 100644
index e4402589..00000000
--- a/utilities/Persistence_representations/persistence_heat_maps/plot_persistence_heat_map.cpp
+++ /dev/null
@@ -1,42 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_heat_maps.h>
-
-#include <iostream>
-#include <sstream>
-
-using constant_scaling_function = Gudhi::Persistence_representations::constant_scaling_function;
-using Persistence_heat_maps = Gudhi::Persistence_representations::Persistence_heat_maps<constant_scaling_function>;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates a gnuplot script from a persistence heat maps stored in a file (the file needs "
- << "to be created beforehand). Please call the code with the name of a single heat maps file \n";
- if (argc != 2) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
- Persistence_heat_maps l;
- l.load_from_file(argv[1]);
- l.plot(argv[1]);
- return 0;
-}