summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/persistence_intervals/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/Persistence_representations/persistence_intervals/CMakeLists.txt')
-rw-r--r--utilities/Persistence_representations/persistence_intervals/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/utilities/Persistence_representations/persistence_intervals/CMakeLists.txt b/utilities/Persistence_representations/persistence_intervals/CMakeLists.txt
new file mode 100644
index 00000000..897e12a3
--- /dev/null
+++ b/utilities/Persistence_representations/persistence_intervals/CMakeLists.txt
@@ -0,0 +1,32 @@
+cmake_minimum_required(VERSION 2.6)
+project(Persistence_representations_intervals_utilities)
+
+
+add_executable ( plot_histogram_of_intervals_lengths plot_histogram_of_intervals_lengths.cpp )
+
+add_test(NAME plot_histogram_of_intervals_lengths COMMAND $<TARGET_FILE:plot_histogram_of_intervals_lengths>
+ "${CMAKE_CURRENT_BINARY_DIR}/../first.pers" "-1")
+
+add_persistence_representation_plot_utility(plot_persistence_intervals "")
+add_persistence_representation_plot_utility(plot_persistence_Betti_numbers "")
+
+add_persistence_representation_creation_utility(compute_birth_death_range_in_persistence_diagram "-1")
+
+
+add_executable ( compute_number_of_dominant_intervals compute_number_of_dominant_intervals.cpp )
+add_test(NAME Persistence_representation_utilities_compute_number_of_dominant_intervals
+ COMMAND $<TARGET_FILE:compute_number_of_dominant_intervals>
+ "${CMAKE_CURRENT_BINARY_DIR}/../first.pers" "-1" "2")
+
+
+if (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)
+ add_executable ( compute_bottleneck_distance compute_bottleneck_distance.cpp )
+ if (TBB_FOUND)
+ target_link_libraries(compute_bottleneck_distance ${TBB_LIBRARIES})
+ endif(TBB_FOUND)
+ add_test(NAME Persistence_representation_utilities_compute_bottleneck_distance
+ COMMAND $<TARGET_FILE:compute_bottleneck_distance>
+ "-1"
+ "${CMAKE_CURRENT_BINARY_DIR}/../first.pers"
+ "${CMAKE_CURRENT_BINARY_DIR}/../second.pers")
+endif (NOT CGAL_WITH_EIGEN3_VERSION VERSION_LESS 4.8.1)