summaryrefslogtreecommitdiff
path: root/utilities/Persistence_representations/persistence_vectors
diff options
context:
space:
mode:
Diffstat (limited to 'utilities/Persistence_representations/persistence_vectors')
-rw-r--r--utilities/Persistence_representations/persistence_vectors/CMakeLists.txt9
-rw-r--r--utilities/Persistence_representations/persistence_vectors/average_persistence_vectors.cpp65
-rw-r--r--utilities/Persistence_representations/persistence_vectors/compute_distance_of_persistence_vectors.cpp94
-rw-r--r--utilities/Persistence_representations/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp86
-rw-r--r--utilities/Persistence_representations/persistence_vectors/create_persistence_vectors.cpp69
-rw-r--r--utilities/Persistence_representations/persistence_vectors/plot_persistence_vectors.cpp43
6 files changed, 0 insertions, 366 deletions
diff --git a/utilities/Persistence_representations/persistence_vectors/CMakeLists.txt b/utilities/Persistence_representations/persistence_vectors/CMakeLists.txt
deleted file mode 100644
index bc982094..00000000
--- a/utilities/Persistence_representations/persistence_vectors/CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-project(Persistence_vectors_utilities)
-
-add_persistence_representation_creation_utility(create_persistence_vectors "-1")
-
-add_persistence_representation_plot_utility(plot_persistence_vectors ".vect")
-
-add_persistence_representation_function_utility(average_persistence_vectors ".vect")
-add_persistence_representation_function_utility(compute_distance_of_persistence_vectors ".vect" "1")
-add_persistence_representation_function_utility(compute_scalar_product_of_persistence_vectors ".vect")
diff --git a/utilities/Persistence_representations/persistence_vectors/average_persistence_vectors.cpp b/utilities/Persistence_representations/persistence_vectors/average_persistence_vectors.cpp
deleted file mode 100644
index 45199838..00000000
--- a/utilities/Persistence_representations/persistence_vectors/average_persistence_vectors.cpp
+++ /dev/null
@@ -1,65 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_vectors.h>
-
-#include <iostream>
-#include <vector>
-
-using Euclidean_distance = Gudhi::Euclidean_distance;
-using Vector_distances_in_diagram = Gudhi::Persistence_representations::Vector_distances_in_diagram<Euclidean_distance>;
-
-int main(int argc, char** argv) {
- std::cout << "This program computes average of persistence vectors stored in files (the files needs to "
- << "be created beforehand).\n"
- << "The parameters of this programs are names of files with persistence vectors.\n";
-
- if (argc < 3) {
- std::cout << "Wrong number of parameters, the program will now terminate \n";
- return 1;
- }
-
- std::vector<const char*> filenames;
- for (int i = 1; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- std::vector<Vector_distances_in_diagram*> lands;
- for (size_t i = 0; i != filenames.size(); ++i) {
- Vector_distances_in_diagram* l = new Vector_distances_in_diagram;
- l->load_from_file(filenames[i]);
- lands.push_back(l);
- }
-
- Vector_distances_in_diagram av;
- av.compute_average(lands);
-
- av.print_to_file("average.vect");
-
- for (size_t i = 0; i != filenames.size(); ++i) {
- delete lands[i];
- }
-
- std::cout << "Done \n";
-
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_vectors/compute_distance_of_persistence_vectors.cpp b/utilities/Persistence_representations/persistence_vectors/compute_distance_of_persistence_vectors.cpp
deleted file mode 100644
index 0db7dbec..00000000
--- a/utilities/Persistence_representations/persistence_vectors/compute_distance_of_persistence_vectors.cpp
+++ /dev/null
@@ -1,94 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_vectors.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using Euclidean_distance = Gudhi::Euclidean_distance;
-using Vector_distances_in_diagram = Gudhi::Persistence_representations::Vector_distances_in_diagram<Euclidean_distance>;
-
-int main(int argc, char** argv) {
- std::cout << "This program compute distance of persistence vectors stored in a file (the file needs to be created "
- "beforehand). \n";
- std::cout << "The first parameter of a program is an integer p. The program compute l^p distance of the vectors. For "
- "l^infty distance choose p = -1. \n";
- std::cout << "The remaining parameters of this programs are names of files with persistence vectors.\n";
-
- if (argc < 3) {
- std::cout << "Wrong number of parameters, the program will now terminate \n";
- return 1;
- }
-
- int pp = atoi(argv[1]);
- double p = std::numeric_limits<double>::max();
- if (pp != -1) {
- p = pp;
- }
-
- std::vector<const char*> filenames;
- for (int i = 2; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
- std::vector<Vector_distances_in_diagram> vectors;
- vectors.reserve(filenames.size());
- for (size_t file_no = 0; file_no != filenames.size(); ++file_no) {
- Vector_distances_in_diagram l;
- l.load_from_file(filenames[file_no]);
- vectors.push_back(l);
- }
-
- // and now we will compute the scalar product of landscapes.
-
- // first we prepare an array:
- std::vector<std::vector<double> > distance(filenames.size());
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::vector<double> v(filenames.size(), 0);
- distance[i] = v;
- }
-
- // and now we can compute the distances:
- for (size_t i = 0; i != vectors.size(); ++i) {
- for (size_t j = i + 1; j != vectors.size(); ++j) {
- distance[i][j] = distance[j][i] = vectors[i].distance(vectors[j], p);
- }
- }
-
- // and now output the result to the screen and a file:
- std::ofstream out;
- out.open("distance.vect");
- for (size_t i = 0; i != distance.size(); ++i) {
- for (size_t j = 0; j != distance.size(); ++j) {
- std::cout << distance[i][j] << " ";
- out << distance[i][j] << " ";
- }
- std::cout << std::endl;
- out << std::endl;
- }
- out.close();
-
- std::cout << "Distance can be found in 'distance.vect' file\n";
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp b/utilities/Persistence_representations/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp
deleted file mode 100644
index 8e99251b..00000000
--- a/utilities/Persistence_representations/persistence_vectors/compute_scalar_product_of_persistence_vectors.cpp
+++ /dev/null
@@ -1,86 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_vectors.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using Euclidean_distance = Gudhi::Euclidean_distance;
-using Vector_distances_in_diagram = Gudhi::Persistence_representations::Vector_distances_in_diagram<Euclidean_distance>;
-
-int main(int argc, char** argv) {
- std::cout << "This program computes scalar product of persistence vectors stored in a file (the file needs to "
- << "be created beforehand). \n"
- << "The parameters of this programs are names of files with persistence vectors.\n";
-
- if (argc < 3) {
- std::cout << "Wrong number of parameters, the program will now terminate \n";
- return 1;
- }
-
- std::vector<const char*> filenames;
- for (int i = 1; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
- std::vector<Vector_distances_in_diagram> vectors;
- vectors.reserve(filenames.size());
- for (size_t file_no = 0; file_no != filenames.size(); ++file_no) {
- Vector_distances_in_diagram l;
- l.load_from_file(filenames[file_no]);
- vectors.push_back(l);
- }
-
- // and now we will compute the scalar product of landscapes.
-
- // first we prepare an array:
- std::vector<std::vector<double> > scalar_product(filenames.size());
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::vector<double> v(filenames.size(), 0);
- scalar_product[i] = v;
- }
-
- // and now we can compute the scalar product:
- for (size_t i = 0; i != vectors.size(); ++i) {
- for (size_t j = i; j != vectors.size(); ++j) {
- scalar_product[i][j] = scalar_product[j][i] = vectors[i].compute_scalar_product(vectors[j]);
- }
- }
-
- // and now output the result to the screen and a file:
- std::ofstream out;
- out.open("scalar_product.vect");
- for (size_t i = 0; i != scalar_product.size(); ++i) {
- for (size_t j = 0; j != scalar_product.size(); ++j) {
- std::cout << scalar_product[i][j] << " ";
- out << scalar_product[i][j] << " ";
- }
- std::cout << std::endl;
- out << std::endl;
- }
- out.close();
-
- std::cout << "Distance can be found in 'scalar_product.vect' file\n";
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_vectors/create_persistence_vectors.cpp b/utilities/Persistence_representations/persistence_vectors/create_persistence_vectors.cpp
deleted file mode 100644
index 364284e5..00000000
--- a/utilities/Persistence_representations/persistence_vectors/create_persistence_vectors.cpp
+++ /dev/null
@@ -1,69 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_vectors.h>
-
-#include <iostream>
-#include <sstream>
-#include <limits>
-#include <vector>
-
-using Euclidean_distance = Gudhi::Euclidean_distance;
-using Vector_distances_in_diagram = Gudhi::Persistence_representations::Vector_distances_in_diagram<Euclidean_distance>;
-
-int main(int argc, char** argv) {
- std::cout << "This program creates persistence vectors files (*.vect) of persistence diagrams files (*.pers) "
- << "provided as an input.\n"
- << "The first parameter of this program is a dimension of persistence that will be used in creation of "
- << "the persistence heat maps."
- << "If your input files contains persistence pairs of various dimension, as a first parameter of the "
- << "procedure please provide the dimension of persistence you want to use."
- << "If in your files there are only birth-death pairs of the same dimension, set the first parameter to "
- << "-1.\n"
- << "The remaining parameters are the names of files with persistence diagrams. \n";
-
- if (argc < 3) {
- std::cout << "Wrong parameter list, the program will now terminate \n";
- return 1;
- }
-
- std::cout << "The remaining parameters are the names of files with persistence diagrams. \n";
- int dim = atoi(argv[1]);
- unsigned dimension = std::numeric_limits<unsigned>::max();
- if (dim >= 0) {
- dimension = (unsigned)dim;
- }
-
- std::vector<const char*> filenames;
- for (int i = 2; i < argc; ++i) {
- filenames.push_back(argv[i]);
- }
-
- for (size_t i = 0; i != filenames.size(); ++i) {
- std::cerr << "Creating persistence vectors based on a file : " << filenames[i] << std::endl;
- Vector_distances_in_diagram l(filenames[i], dimension);
- std::stringstream ss;
- ss << filenames[i] << ".vect";
- l.print_to_file(ss.str().c_str());
- }
- return 0;
-}
diff --git a/utilities/Persistence_representations/persistence_vectors/plot_persistence_vectors.cpp b/utilities/Persistence_representations/persistence_vectors/plot_persistence_vectors.cpp
deleted file mode 100644
index 550e47c5..00000000
--- a/utilities/Persistence_representations/persistence_vectors/plot_persistence_vectors.cpp
+++ /dev/null
@@ -1,43 +0,0 @@
-/* This file is part of the Gudhi Library. The Gudhi library
- * (Geometric Understanding in Higher Dimensions) is a generic C++
- * library for computational topology.
- *
- * Author(s): Pawel Dlotko
- *
- * Copyright (C) 2016 Inria
- *
- * This program is free software: you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation, either version 3 of the License, or
- * (at your option) any later version.
- *
- * This program is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program. If not, see <http://www.gnu.org/licenses/>.
- */
-
-#include <gudhi/Persistence_vectors.h>
-
-#include <iostream>
-#include <sstream>
-
-using Euclidean_distance = Gudhi::Euclidean_distance;
-using Vector_distances_in_diagram = Gudhi::Persistence_representations::Vector_distances_in_diagram<Euclidean_distance>;
-
-int main(int argc, char** argv) {
- std::cout << "This program create a Gnuplot script to plot persistence vector. Please call this program with the "
- "name of file with persistence vector. \n";
- if (argc != 2) {
- std::cout << "Wrong number of parameters, the program will now terminate. \n";
- return 1;
- }
- Vector_distances_in_diagram l;
- l.load_from_file(argv[1]);
- l.plot(argv[1]);
-
- return 0;
-}