summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMihai Capotă <mihai@mihaic.ro>2016-11-23 14:23:42 -0800
committerMihai Capotă <mihai@mihaic.ro>2016-11-23 14:23:42 -0800
commit0dc635b981cf111b41ffd13115b21d8985f867b1 (patch)
tree8b624ed7f2f557398653ef83f405f4f10b7a011e
parent1d186c730074700995c3139af73267e9e498990a (diff)
Add support for user level pybind11 installations
Currently, when pybind11 is installed using the `--user` flag of pip, its headers are not found.
-rw-r--r--python/setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
index 556b722..f366e88 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -42,6 +42,7 @@ class BuildExt(build_ext):
for ext in self.extensions:
ext.extra_compile_args = opts
ext.include_dirs.append(pybind11.get_include())
+ ext.include_dirs.append(pybind11.get_include(user=True))
build_ext.build_extensions(self)
setup(