summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryn Keller <xoltar@xoltar.org>2016-05-10 13:33:56 -0700
committerBryn Keller <xoltar@xoltar.org>2016-05-10 13:33:56 -0700
commit1d186c730074700995c3139af73267e9e498990a (patch)
tree4de4dd82e9b29dc276b6ce6e45048122625018d0
parent2f3ed798d26ae4ab31b0b45e5ef5305c58b28be1 (diff)
Setup.py checks for Python 2.7.11 or greater
-rw-r--r--python/setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
index 133a204..556b722 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -4,6 +4,11 @@ import sys
import os.path
from io import open
+if sys.version_info < (2, 7, 11):
+ print("Sorry, PHAT requires Python 2.7.11 or later")
+ sys.exit(1)
+
+
ext_modules = [
Extension(
'_phat',