summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Bauer <mail@ulrich-bauer.org>2016-12-12 15:00:16 +0100
committerUlrich Bauer <mail@ulrich-bauer.org>2016-12-12 15:00:16 +0100
commitbb5407b3dfc05cdfef6d4260c81750926d882843 (patch)
tree303b1165ebe8ceabb131bffab345acebeaa5a3da
parent2627c54de7891fbb5b9c3df72167d8c117058561 (diff)
parentd8ef50e225f7abfbf8d085c808e77857827e5274 (diff)
Merge commit 'd8ef50e225f7abfbf8d085c808e77857827e5274' into python-pr
* commit 'd8ef50e225f7abfbf8d085c808e77857827e5274': Added note that phat module can be installed with pip, without downloading source Updated readme.md to mention the Python bindings, set python bindings version number to 1.5.0 to match main project version
-rw-r--r--README.md4
-rw-r--r--python/README.rst6
-rw-r--r--setup.py4
3 files changed, 12 insertions, 2 deletions
diff --git a/README.md b/README.md
index f166ee2..e942f95 100644
--- a/README.md
+++ b/README.md
@@ -134,6 +134,10 @@ Supported Platforms:
* Visual Studio 2008 and 2012 (2010 untested)
* GCC version 4.4. and higher
+## Python Bindings ##
+We provide bindings for Python 3.x and 2.7.12+, which are installable using `pip`. Please see
+the Python-specific README.rst in the `python` folder of this repository for details.
+
References:
1. H.Edelsbrunner, J.Harer: Computational Topology, An Introduction. American Mathematical Society, 2010, ISBN 0-8218-4925-5
diff --git a/python/README.rst b/python/README.rst
index 7d9a1e6..0c6c391 100644
--- a/python/README.rst
+++ b/python/README.rst
@@ -43,6 +43,12 @@ the algorithm. We provide the following choices of representation classes:
Installation
------------
+If you wish to use the released version of PHAT, you can simply install from PyPI::
+
+ pip install phat
+
+Installation from Source
+------------------------
Suppose you have checked out the PHAT repository at location $PHAT. Then you can::
cd $PHAT
diff --git a/setup.py b/setup.py
index 6d082d7..1ce0e51 100644
--- a/setup.py
+++ b/setup.py
@@ -51,11 +51,11 @@ if sys.version_info < (3,4,0):
setup(
name='phat',
- version='0.0.1',
+ version='1.5.0',
author='Bryn Keller',
author_email='bryn.keller@intel.com',
url='https://bitbucket.org/phat-code/phat',
- description='Python bindings for PHAT',
+ description='Python bindings for PHAT, the C++ based Persistent Homology Algorithm Toolbox',
license = 'LGPL',
keywords='algebraic-topology PHAT distributed topology persistent-homology',
long_description=long_description,