summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2019-01-30 13:23:01 +0100
committerGard Spreemann <gspreemann@gmail.com>2019-01-30 13:23:01 +0100
commitebd2542fe655b6d24e50c51153f9815e5285fe13 (patch)
tree7a832d33bfc8b8424c5e95bd63b1a8e1e7c84f9c
parent0cfa802d9155817d307617b60726949e2efe3b11 (diff)
Patch to not force the CMAKE build type.
-rw-r--r--debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch20
-rw-r--r--debian/patches/series1
2 files changed, 21 insertions, 0 deletions
diff --git a/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch b/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch
new file mode 100644
index 0000000..6858726
--- /dev/null
+++ b/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch
@@ -0,0 +1,20 @@
+From: Gard Spreemann <gspreemann@gmail.com>
+Date: Wed, 30 Jan 2019 13:22:13 +0100
+Subject: Don't force CMAKE_BUILD_TYPE=Release.
+
+---
+ CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1d2c34e..f010cac 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -2,7 +2,6 @@ cmake_minimum_required(VERSION 2.8)
+
+ project("Phat")
+
+-set(CMAKE_BUILD_TYPE "Release")
+
+ INCLUDE(CheckCXXSourceCompiles)
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..1e0f266
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch