summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGard Spreemann <gspreemann@gmail.com>2019-02-08 11:05:28 +0100
committerGard Spreemann <gspreemann@gmail.com>2019-02-08 13:24:19 +0100
commit9ed3de0085f807c3ebc5ce185ea36cc441af9722 (patch)
tree036f8d2e476dc43474ea7aca8b1b9d3b123ed9c0
parentc2a29bb23e7824b2b8e10e899918e264bdaa702a (diff)
Update CMAKE_BUILD_TYPE patch to be more upstreamable, allowing a default build type.
-rw-r--r--debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch b/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch
index 6858726..c8f17e8 100644
--- a/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch
+++ b/debian/patches/0001-Don-t-force-CMAKE_BUILD_TYPE-Release.patch
@@ -3,18 +3,21 @@ Date: Wed, 30 Jan 2019 13:22:13 +0100
Subject: Don't force CMAKE_BUILD_TYPE=Release.
---
- CMakeLists.txt | 1 -
- 1 file changed, 1 deletion(-)
+ CMakeLists.txt | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1d2c34e..f010cac 100644
+index 1d2c34e..7417d30 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -2,7 +2,6 @@ cmake_minimum_required(VERSION 2.8)
+@@ -2,7 +2,9 @@ cmake_minimum_required(VERSION 2.8)
project("Phat")
-set(CMAKE_BUILD_TYPE "Release")
++if (NOT CMAKE_BUILD_TYPE)
++ set(CMAKE_BUILD_TYPE "Release")
++endif()
INCLUDE(CheckCXXSourceCompiles)