summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryn Keller <xoltar@xoltar.org>2016-12-08 15:52:34 -0800
committerBryn Keller <xoltar@xoltar.org>2016-12-08 15:52:34 -0800
commitbeadd363d0a78cea8718a605ed1364feb790770c (patch)
tree9055cccb238b6e2395019775ffd5bbe2bf198d44
parentcdcf5f101523ca2edc497a8de559b2c538ddbd89 (diff)
Updated readme.md to mention the Python bindings, set python bindings version number to 1.5.0 to match main project version
-rw-r--r--README.md4
-rw-r--r--setup.py4
2 files changed, 6 insertions, 2 deletions
diff --git a/README.md b/README.md
index 9a30ffa..0f83bc9 100644
--- a/README.md
+++ b/README.md
@@ -133,6 +133,10 @@ Supported Platforms:
* Visual Studio 2008 and 2012 (2010 untested)
* GCC version 4.4. and higher
+## Python Bindings ##
+We provide bindings for Python 3.x and 2.7.12+, which are installable using `pip`. Please see
+the Python-specific README.rst in the `python` folder of this repository for details.
+
References:
1. H.Edelsbrunner, J.Harer: Computational Topology, An Introduction. American Mathematical Society, 2010, ISBN 0-8218-4925-5
diff --git a/setup.py b/setup.py
index 6d082d7..1ce0e51 100644
--- a/setup.py
+++ b/setup.py
@@ -51,11 +51,11 @@ if sys.version_info < (3,4,0):
setup(
name='phat',
- version='0.0.1',
+ version='1.5.0',
author='Bryn Keller',
author_email='bryn.keller@intel.com',
url='https://bitbucket.org/phat-code/phat',
- description='Python bindings for PHAT',
+ description='Python bindings for PHAT, the C++ based Persistent Homology Algorithm Toolbox',
license = 'LGPL',
keywords='algebraic-topology PHAT distributed topology persistent-homology',
long_description=long_description,