summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorulrich.bauer@gmail.com <ulrich.bauer@gmail.com@8e3bb3c2-eed4-f18f-5264-0b6c94e6926d>2013-04-30 09:19:22 +0000
committerulrich.bauer@gmail.com <ulrich.bauer@gmail.com@8e3bb3c2-eed4-f18f-5264-0b6c94e6926d>2013-04-30 09:19:22 +0000
commit204f8ace0554cb8290a7f8cfca947d4a1251f985 (patch)
treef49575e1fc8fdf9a161d7ccec0c67703c0615965 /CMakeLists.txt
parentcd068718368ef7e2e45e7382b45f61a6f2ef680a (diff)
alpha shape creation update
git-svn-id: https://phat.googlecode.com/svn/trunk@50 8e3bb3c2-eed4-f18f-5264-0b6c94e6926d
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 98ffc17..923a069 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,6 +5,7 @@ set(CMAKE_BUILD_TYPE "Release")
INCLUDE(CheckCXXSourceCompiles)
include_directories (include)
+include_directories (/opt/local/include)
FIND_PACKAGE(OpenMP)
@@ -38,3 +39,24 @@ endif()
add_executable (simple_example src/simple_example.cpp)
add_executable (self_test src/self_test.cpp)
add_executable (phat src/phat.cpp)
+add_executable (reduction_test reduction_test.cpp)
+add_executable (benchmark src/benchmark.cpp)
+
+
+set(CMAKE_MODULE_PATH "modules")
+set(CGAL_DIR "/opt/local/lib/cmake")
+
+FIND_PACKAGE(CGAL)
+
+if ( CGAL_FOUND )
+
+ include( ${CGAL_USE_FILE} )
+else()
+
+ message(STATUS "This program requires the CGAL library, and will not be compiled.")
+
+endif()
+
+FIND_PACKAGE(Boost)
+
+add_executable (alpha_3 addons/alpha_3.cpp)